fixes etables CONFIG_* selection for >= 2.6.25, fixes #3674
authorJohn Crispin <john@openwrt.org>
Wed, 30 Jul 2008 00:58:36 +0000 (00:58 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 30 Jul 2008 00:58:36 +0000 (00:58 +0000)
SVN-Revision: 12002

package/kernel/modules/netfilter.mk

index 802edac7d7f0196dee98f76aeb1d49a387a6988b..31c6287a5d976fab7ecbb1b5f7846983b5fe8d41 100644 (file)
@@ -301,13 +301,13 @@ endef
 
 $(eval $(call KernelPackage,arptables))
 
-
 define KernelPackage/ebtables
   SUBMENU:=$(NF_MENU)
   TITLE:=Bridge firewalling modules
   DEPENDS:=@LINUX_2_6
   FILES:=$(LINUX_DIR)/net/bridge/netfilter/*.$(LINUX_KMOD_SUFFIX)
-  KCONFIG:=CONFIG_BRIDGE_NF_EBTABLES
+  KCONFIG:=CONFIG_BRIDGE_NETFILTER=y \
+       CONFIG_BRIDGE_NF_EBTABLES
   AUTOLOAD:=$(call AutoLoad,40,$(notdir $(patsubst %.ko,%,ebtables.ko $(wildcard $(LINUX_DIR)/net/bridge/netfilter/ebtable_*.$(LINUX_KMOD_SUFFIX)) $(wildcard $(LINUX_DIR)/net/bridge/netfilter/ebt_*.$(LINUX_KMOD_SUFFIX)))))
 endef