[packages] aprx: prevent spurious rebuilds caused by PKG_BUILD_DIR containing .svn...
authorNicolas Thill <nico@openwrt.org>
Tue, 6 Apr 2010 09:36:43 +0000 (09:36 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 6 Apr 2010 09:36:43 +0000 (09:36 +0000)
SVN-Revision: 20732

net/aprx/Makefile

index e5f5c8f03f5d11ce05e5207e8333cf30d6668e35..6907fd787b96e29895814391f7255e776fa6e351 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aprx
-PKG_VERSION:=0.99
-PKG_RELEASE:=svn121
+PKG_REV:=121
+PKG_VERSION:=0.99_r$(PKG_REV)
+PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).$(PKG_RELEASE).tar.gz
-PKG_SOURCE_URL:=http://ham.zmailer.org/oh2mqk/aprx
-PKG_MD5SUM:=095ec0aa24432196002ae717593bfe5c
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION).$(PKG_RELEASE)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://repo.ham.fi/svn/aprx/trunk/
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE_PROTO:=svn
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -31,11 +32,8 @@ define Package/aprx/description
        It then forwards appropriate packets to APRS-IS servers.
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --with-embedded \
-       )
-endef
+CONFIGURE_ARGS += \
+       --with-embedded \
 
 define Package/aprx/install    
        $(INSTALL_DIR) $(1)/etc/init.d