at: disable linking with libpam
authorFlorian Fainelli <florian@openwrt.org>
Tue, 11 Mar 2014 04:30:14 +0000 (04:30 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 11 Mar 2014 04:30:14 +0000 (04:30 +0000)
In case the host has security/pam_appl.h, the at configure script will
decide to link against libpam, we do not want that.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 39866

utils/at/Makefile

index 7c02fb86e72515c8af504be22227dee1b632400b..389e62035d33a700022e648e3c1321c31481fcee 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2012 OpenWrt.org
+# Copyright (C) 2008-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=at
 PKG_VERSION:=3.1.13
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/a/at
@@ -41,6 +41,9 @@ CONFIGURE_ARGS+=--prefix=/usr \
                --with-jobdir=/var/spool/cron/atjobs \
                --with-atspool=/var/spool/cron/atspool
 
+CONFIGURE_VARS += \
+       ac_cv_header_security_pam_appl_h=no
+
 define Package/at/install
        $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/sbin $(1)/etc/init.d/
        $(INSTALL_BIN) ./files/atd.init $(1)/etc/init.d/atd