package/kexec-tools: move configuration in submenu, rename 'kexec-config.in' in ...
authorNicolas Thill <nico@openwrt.org>
Fri, 16 Apr 2010 11:03:50 +0000 (11:03 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 16 Apr 2010 11:03:50 +0000 (11:03 +0000)
SVN-Revision: 20916

package/kexec-tools/Config.in [new file with mode: 0644]
package/kexec-tools/Makefile
package/kexec-tools/kexec-config.in [deleted file]

diff --git a/package/kexec-tools/Config.in b/package/kexec-tools/Config.in
new file mode 100644 (file)
index 0000000..60c819d
--- /dev/null
@@ -0,0 +1,21 @@
+menu "Configuration"
+       depends on PACKAGE_kexec-tools
+
+config KEXEC_TOOLS_TARGET_NAME
+       string
+       prompt "Target name for kexec kernel"
+       default EXTRA_TARGET_ARCH_NAME  if powerpc64
+       default ARCH
+       help
+         Defines the target type of the kernels that kexec deals
+         with. This should be the target specification of
+         the kernel you're booting.
+
+config KEXEC_TOOLS_kdump
+       bool
+       prompt "kdump support"
+       default n
+       help
+         Include the kdump utility.
+
+endmenu
index d350bb2c8b6157a3b5c8106a7752beb9b9cc811d..978bb6fd504f1e549d5e0dbc688a892d73d4fe1f 100644 (file)
@@ -34,7 +34,7 @@ define Package/kexec-tools/description
 endef
 
 define Package/kexec-tools/config
-       source "$(SOURCE)/kexec-config.in"
+       source "$(SOURCE)/Config.in"
 endef
 
 KEXEC_TARGET_NAME:=$(call qstrip,$(CONFIG_KEXEC_TOOLS_TARGET_NAME))-linux-$(TARGET_SUFFIX)
diff --git a/package/kexec-tools/kexec-config.in b/package/kexec-tools/kexec-config.in
deleted file mode 100644 (file)
index 25fed1b..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-
-config KEXEC_TOOLS_TARGET_NAME
-       string
-       prompt "Target name for kexec kernel" if PACKAGE_kexec-tools
-       default EXTRA_TARGET_ARCH_NAME  if powerpc64
-       default ARCH
-       help
-         Defines the target type of the kernels that kexec deals
-         with. This should be the target specification of
-         the kernel you're booting.
-
-config KEXEC_TOOLS_kdump
-       bool
-       prompt "kdump support"
-       depends on PACKAGE_kexec-tools
-       default n
-       help
-         Include the kdump utility.
-