[packages] git: update to 1.7.11.2
authorLuka Perkov <luka@openwrt.org>
Sun, 15 Jul 2012 14:55:24 +0000 (14:55 +0000)
committerLuka Perkov <luka@openwrt.org>
Sun, 15 Jul 2012 14:55:24 +0000 (14:55 +0000)
SVN-Revision: 32733

net/git/Makefile
net/git/patches/100-convert_builtin.patch

index 21abb28add8fc5fbc8efcc2253ac18986aeaeddb..3373941832836eb67d9fc0b07a83e2e473a7c5ee 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=git
-PKG_VERSION:=1.7.11
+PKG_VERSION:=1.7.11.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://git-core.googlecode.com/files/
-PKG_MD5SUM:=0beee35ec7d11756f51ca1d3ec5c0e16
+PKG_MD5SUM:=91e01a22032f5d0ca2941ae7fd49d587
 
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
index 0285425ccc7883e8fb8cbb83f8b317aa935bf4cf..21a6a72da0e949e49aa6dd58f900e85859665fdd 100644 (file)
@@ -24,7 +24,7 @@
 +#include "../upload-pack.c"
 --- a/builtin.h
 +++ b/builtin.h
-@@ -151,5 +151,11 @@ extern int cmd_verify_pack(int argc, con
+@@ -153,5 +153,11 @@ extern int cmd_verify_pack(int argc, con
  extern int cmd_show_ref(int argc, const char **argv, const char *prefix);
  extern int cmd_pack_refs(int argc, const char **argv, const char *prefix);
  extern int cmd_replace(int argc, const char **argv, const char *prefix);
                { "verify-tag", cmd_verify_tag, RUN_SETUP },
 --- a/Makefile
 +++ b/Makefile
-@@ -464,15 +464,7 @@ EXTRA_PROGRAMS =
+@@ -467,15 +467,7 @@ EXTRA_PROGRAMS =
  # ... and all the rest that could be moved out of bindir to gitexecdir
  PROGRAMS += $(EXTRA_PROGRAMS)
  
  
  # Binary suffix, set to .exe for Windows builds
  X =
-@@ -900,6 +892,12 @@ BUILTIN_OBJS += builtin/var.o
+@@ -903,6 +895,12 @@ BUILTIN_OBJS += builtin/var.o
  BUILTIN_OBJS += builtin/verify-pack.o
  BUILTIN_OBJS += builtin/verify-tag.o
  BUILTIN_OBJS += builtin/write-tree.o
  
  GITLIBS = $(LIB_FILE) $(XDIFF_LIB)
  EXTLIBS =
-@@ -1498,7 +1496,7 @@ endif
+@@ -1502,7 +1500,7 @@ endif
  EXTLIBS += -lz
  
  ifndef NO_OPENSSL
        ifdef OPENSSLDIR
                BASIC_CFLAGS += -I$(OPENSSLDIR)/include
                OPENSSL_LINK = -L$(OPENSSLDIR)/$(lib) $(CC_LD_DYNPATH)$(OPENSSLDIR)/$(lib)
-@@ -2279,10 +2277,6 @@ endif
+@@ -2287,10 +2285,6 @@ endif
  git-%$X: %.o GIT-LDFLAGS $(GITLIBS)
        $(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) $(LIBS)
  
  git-http-fetch$X: revision.o http.o http-walker.o http-fetch.o GIT-LDFLAGS $(GITLIBS)
        $(QUIET_LINK)$(CC) $(ALL_CFLAGS) -o $@ $(ALL_LDFLAGS) $(filter %.o,$^) \
                $(LIBS) $(CURL_LIBCURL)
-@@ -2579,24 +2573,22 @@ endif
+@@ -2587,24 +2581,22 @@ endif
        bindir=$$(cd '$(DESTDIR_SQ)$(bindir_SQ)' && pwd) && \
        execdir=$$(cd '$(DESTDIR_SQ)$(gitexec_instdir_SQ)' && pwd) && \
        { test "$$bindir/" = "$$execdir/" || \