add scdp package (thanks to Florian Fainelli)
authorNicolas Thill <nico@openwrt.org>
Wed, 19 Oct 2005 11:29:33 +0000 (11:29 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 19 Oct 2005 11:29:33 +0000 (11:29 +0000)
SVN-Revision: 2179

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/scdp/Config.in [new file with mode: 0644]
openwrt/package/scdp/Makefile [new file with mode: 0644]
openwrt/package/scdp/ipkg/scdp.control [new file with mode: 0644]

index e536069676ca5156c6d703cdd12e91cccb7ad0c0..245ddbb69a423c95043263a28e59f5bb86b54ea6 100644 (file)
@@ -106,6 +106,7 @@ source "package/robocfg/Config.in"
 source "package/rrs/Config.in"
 source "package/rsync/Config.in"
 source "package/samba/Config.in"
+source "package/scdp/Config.in"
 source "package/ser/Config.in"
 source "package/shat/Config.in"
 source "package/siproxd/Config.in"
index 5e5087d92515e562cf669a67868889051f379dc1..ab95cab6c5f948ee9d85cfae5a8f304636489aae 100644 (file)
@@ -163,6 +163,7 @@ package-$(BR2_PACKAGE_RSYNC) += rsync
 package-$(BR2_PACKAGE_SABLEVM) += sablevm
 package-$(BR2_PACKAGE_SABLEVM_CLASSPATH) += sablevm-classpath
 package-$(BR2_COMPILE_SAMBA) += samba
+package-$(BR2_PACKAGE_SCDP) += scdp
 package-$(BR2_PACKAGE_SCREEN) += screen
 package-$(BR2_PACKAGE_SDK) += sdk
 package-$(BR2_PACKAGE_SER) += ser
@@ -277,6 +278,7 @@ endif
 rrdtool-compile: cgilib-compile freetype-compile libart-compile libpng-compile
 rrdtool1-compile: zlib-compile
 rsync-compile: popt-compile
+scdp-compile: libnet-compile
 screen-compile: ncurses-compile
 siproxd-compile: libosip2-compile
 sipsak-compile: openssl-compile
diff --git a/openwrt/package/scdp/Config.in b/openwrt/package/scdp/Config.in
new file mode 100644 (file)
index 0000000..507cdb8
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_SCDP
+       tristate "scdp - an utility to send CDP (Cisco Discovery Protocol) packets"
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_LIBNET
+       help
+         This program sends CDP (Cisco Discovery Protocol) packets out on 
+         selected interfaces and tells the connected switch (cisco only) 
+         where the host is connected.
+         
+         http://sourceforge.net/projects/scdp
+         
diff --git a/openwrt/package/scdp/Makefile b/openwrt/package/scdp/Makefile
new file mode 100644 (file)
index 0000000..6f92de9
--- /dev/null
@@ -0,0 +1,63 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=scdp
+PKG_VERSION:=1.0b
+PKG_RELEASE:=1
+PKG_MD5SUM:=7eafaf5a422e37d04715613993ed5d95
+
+PKG_SOURCE_URL:=@SF/scdp
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,SCDP,scdp,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --enable-shared \
+                       --disable-static \
+                       --with-gnu-ld \
+       );
+       touch $(PKG_BUILD_DIR)/.configured
+
+$(PKG_BUILD_DIR)/.built:
+       rm -rf $(PKG_INSTALL_DIR)/
+       mkdir -p $(PKG_INSTALL_DIR)/
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR=$(PKG_INSTALL_DIR) \
+               all install
+       touch $@
+
+$(IPKG_SCDP):
+       install -d -m0755 $(IDIR_SCDP)/usr/bin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/scdp $(IDIR_SCDP)/usr/bin/
+       $(RSTRIP) $(IDIR_SCDP)
+       $(IPKG_BUILD) $(IDIR_SCDP) $(PACKAGE_DIR)
diff --git a/openwrt/package/scdp/ipkg/scdp.control b/openwrt/package/scdp/ipkg/scdp.control
new file mode 100644 (file)
index 0000000..abafc71
--- /dev/null
@@ -0,0 +1,7 @@
+Package: scdp
+Priority: optional
+Section: net
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>, Florian Fainelli <florian@alphacore.net>
+Source: buildroot internal
+Depends: libnet
+Description: An utility to send CDP (Cisco Discovery Protocol) packets.