Link with libgcc_s it would fail otherwise on x86_64-uclibc (and maybe others)
authorFlorian Fainelli <florian@openwrt.org>
Mon, 10 Nov 2008 21:20:30 +0000 (21:20 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 10 Nov 2008 21:20:30 +0000 (21:20 +0000)
SVN-Revision: 13170

net/cbtt/Makefile

index e38aa81b7dd7afb43fe61cff6f17e8b5c88d1901..8377429bbbe7f4ba484e1d1470337544b18c7de0 100644 (file)
@@ -45,7 +45,7 @@ $(STAMP_BUILT)-$(2): $(STAMP_PREPARED)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/include/uClibc++ -fno-builtin -nostdinc++" \
-               LFLAGS="$(TARGET_LDFLAGS) -L. -nodefaultlibs $(4) -lz -luClibc++ -lm -lpthread -lgcc" \
+               LFLAGS="$(TARGET_LDFLAGS) -L. -nodefaultlibs $(4) -lz -luClibc++ -lm -lpthread -lgcc_s" \
                $(3)
        touch $$@