[package] move miredo from net to ipv6
authorFlorian Fainelli <florian@openwrt.org>
Thu, 28 May 2009 11:09:40 +0000 (11:09 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 28 May 2009 11:09:40 +0000 (11:09 +0000)
SVN-Revision: 16130

ipv6/miredo/Makefile [new file with mode: 0644]
ipv6/miredo/files/miredo-server.init [new file with mode: 0644]
ipv6/miredo/files/miredo.init [new file with mode: 0644]
ipv6/miredo/patches/100-uclibc.patch [new file with mode: 0644]
ipv6/mrd6/Makefile
net/miredo/Makefile [deleted file]
net/miredo/files/miredo-server.init [deleted file]
net/miredo/files/miredo.init [deleted file]
net/miredo/patches/100-uclibc.patch [deleted file]

diff --git a/ipv6/miredo/Makefile b/ipv6/miredo/Makefile
new file mode 100644 (file)
index 0000000..c7f6bcf
--- /dev/null
@@ -0,0 +1,90 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=miredo
+PKG_VERSION:=1.1.6
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=http://www.remlab.net/files/miredo/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=bf49c1ddc068746760787d0cf76e40de
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/miredo/Default
+  SECTION:=ipv6
+  CATEGORY:=IPv6
+  DEPENDS:=+libpthread +uclibcxx +kmod-ipv6 +kmod-tun
+  SUBMENU:=miredo: Teredo (IPv6 tunneling over UDP through NAT)
+  URL:=http://www.simphalempin.com/dev/miredo/
+endef
+
+define Package/miredo-server
+$(call Package/miredo/Default)
+  TITLE:=Teredo (IPv6 tunneling over UDP through NAT) server daemon
+endef
+
+define Package/miredo-server/conffiles
+/etc/miredo-server.conf
+endef
+
+define Package/miredo-client
+$(call Package/miredo/Default)
+  TITLE:=Teredo (IPv6 tunneling over UDP through NAT) client and relay daemon
+endef
+
+define Package/miredo-client/conffiles
+/etc/miredo.conf
+endef
+
+CONFIGURE_ARGS += \
+       --disable-shared \
+       --enable-static \
+       --with-gnu-ld \
+       --disable-rpath \
+       --disable-chroot \
+       --enable-teredo-client \
+       --enable-teredo-relay \
+       --enable-teredo-server \
+       --enable-miredo-user=root \
+       --without-Judy \
+
+CONFIGURE_VARS += \
+       CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++" \
+       CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++"  \
+       LIBS="-nodefaultlibs -luClibc++ -lm" \
+       ac_cv_file__proc_self_maps=yes\
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CXXLINK="\$$$$(LINK)" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Package/miredo-server/install
+       $(INSTALL_DIR) $(1)/etc/
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/doc/miredo/examples/miredo-server.conf $(1)/etc/miredo-server.conf
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/miredo-server.init $(1)/etc/init.d/miredo-server
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/miredo-server $(1)/usr/sbin/
+endef
+
+define Package/miredo-client/install   
+       $(INSTALL_DIR) $(1)/etc
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/doc/miredo/examples/miredo.conf $(1)/etc/miredo.conf
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/miredo.init $(1)/etc/init.d/miredo
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/miredo $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,miredo-server))
+$(eval $(call BuildPackage,miredo-client))
diff --git a/ipv6/miredo/files/miredo-server.init b/ipv6/miredo/files/miredo-server.init
new file mode 100644 (file)
index 0000000..4d51370
--- /dev/null
@@ -0,0 +1,20 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2006 OpenWrt.org
+START=50
+
+BIN=miredo-server
+DEFAULT=/etc/default/$BIN
+RUN_D=/var/run
+PID_F=$RUN_D/$BIN.pid
+
+start() {
+       [ -f $DEFAULT ] && . $DEFAULT
+       [ -d $RUN_D ] || mkdir -p $RUN_D
+       insmod ipv6
+       insmod tun
+       $BIN $OPTIONS
+}
+
+stop() {
+       [ -f $PID_F ] && kill $(cat $PID_F)
+}
diff --git a/ipv6/miredo/files/miredo.init b/ipv6/miredo/files/miredo.init
new file mode 100644 (file)
index 0000000..90e70c4
--- /dev/null
@@ -0,0 +1,20 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2006 OpenWrt.org
+START=50
+
+BIN=miredo
+DEFAULT=/etc/default/$BIN
+RUN_D=/var/run
+PID_F=$RUN_D/$BIN.pid
+
+start() {
+       [ -f $DEFAULT ] && . $DEFAULT
+       [ -d $RUN_D ] || mkdir -p $RUN_D
+       insmod ipv6
+       insmod tun
+       $BIN $OPTIONS
+}
+
+stop() {
+       [ -f $PID_F ] && kill $(cat $PID_F)
+}
diff --git a/ipv6/miredo/patches/100-uclibc.patch b/ipv6/miredo/patches/100-uclibc.patch
new file mode 100644 (file)
index 0000000..46573fe
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN miredo-1.1.6/libteredo/maintain.c miredo-1.1.6.new/libteredo/maintain.c
+--- miredo-1.1.6/libteredo/maintain.c  2009-04-13 11:15:15.000000000 +0200
++++ miredo-1.1.6.new/libteredo/maintain.c      2009-05-26 16:37:14.000000000 +0200
+@@ -59,7 +59,7 @@
+ static inline void gettime (struct timespec *now)
+ {
+-#if (_POSIX_CLOCK_SELECTION - 0 >= 0) && (_POSIX_MONOTONIC_CLOCK - 0 >= 0)
++#if (_POSIX_CLOCK_SELECTION - 0 >= 0) && (_POSIX_MONOTONIC_CLOCK - 0 >= 0) && !defined(__UCLIBC__)
+       if (clock_gettime (CLOCK_MONOTONIC, now) == 0)
+               return;
+ #else
index 0bd3f440389eb11278a571a6f67c46caba56f76d..1d372d7b89df3ab6d0a9b5168aa54c1726863304 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mrd6
-PKG_VERSION:=0.9.5
-PKG_REVISION:=3
-PKG_RELEASE:=$(PKG_REVISION).1
+PKG_VERSION:=0.9.6
+PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_REVISION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://fivebits.net/files/mrd6/ \
        http://hng.av.it.pt/mrd6/download/
-PKG_MD5SUM:=361322198dafcc5ffab5e8e23197012b
+PKG_MD5SUM:=00221326810358889e811c48cbac415a
+TAR_OPTIONS:=
 
 include $(INCLUDE_DIR)/package.mk
 
diff --git a/net/miredo/Makefile b/net/miredo/Makefile
deleted file mode 100644 (file)
index 04d6528..0000000
+++ /dev/null
@@ -1,90 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=miredo
-PKG_VERSION:=1.1.6
-PKG_RELEASE:=1
-
-PKG_SOURCE_URL:=http://www.remlab.net/files/miredo/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=bf49c1ddc068746760787d0cf76e40de
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/miredo/Default
-  SECTION:=net
-  CATEGORY:=Network
-  DEPENDS:=+libpthread +uclibcxx +kmod-ipv6 +kmod-tun
-  SUBMENU:=miredo: Teredo (IPv6 tunneling over UDP through NAT)
-  URL:=http://www.simphalempin.com/dev/miredo/
-endef
-
-define Package/miredo-server
-$(call Package/miredo/Default)
-  TITLE:=Teredo (IPv6 tunneling over UDP through NAT) server daemon
-endef
-
-define Package/miredo-server/conffiles
-/etc/miredo-server.conf
-endef
-
-define Package/miredo-client
-$(call Package/miredo/Default)
-  TITLE:=Teredo (IPv6 tunneling over UDP through NAT) client and relay daemon
-endef
-
-define Package/miredo-client/conffiles
-/etc/miredo.conf
-endef
-
-CONFIGURE_ARGS += \
-       --disable-shared \
-       --enable-static \
-       --with-gnu-ld \
-       --disable-rpath \
-       --disable-chroot \
-       --enable-teredo-client \
-       --enable-teredo-relay \
-       --enable-teredo-server \
-       --enable-miredo-user=root \
-       --without-Judy \
-
-CONFIGURE_VARS += \
-       CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++" \
-       CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++"  \
-       LIBS="-nodefaultlibs -luClibc++ -lm" \
-       ac_cv_file__proc_self_maps=yes\
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CXXLINK="\$$$$(LINK)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-define Package/miredo-server/install
-       $(INSTALL_DIR) $(1)/etc/
-       $(CP) $(PKG_INSTALL_DIR)/usr/share/doc/miredo/examples/miredo-server.conf $(1)/etc/miredo-server.conf
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/miredo-server.init $(1)/etc/init.d/miredo-server
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/miredo-server $(1)/usr/sbin/
-endef
-
-define Package/miredo-client/install   
-       $(INSTALL_DIR) $(1)/etc
-       $(CP) $(PKG_INSTALL_DIR)/usr/share/doc/miredo/examples/miredo.conf $(1)/etc/miredo.conf
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/miredo.init $(1)/etc/init.d/miredo
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/miredo $(1)/usr/sbin/
-endef
-
-$(eval $(call BuildPackage,miredo-server))
-$(eval $(call BuildPackage,miredo-client))
diff --git a/net/miredo/files/miredo-server.init b/net/miredo/files/miredo-server.init
deleted file mode 100644 (file)
index 4d51370..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
-START=50
-
-BIN=miredo-server
-DEFAULT=/etc/default/$BIN
-RUN_D=/var/run
-PID_F=$RUN_D/$BIN.pid
-
-start() {
-       [ -f $DEFAULT ] && . $DEFAULT
-       [ -d $RUN_D ] || mkdir -p $RUN_D
-       insmod ipv6
-       insmod tun
-       $BIN $OPTIONS
-}
-
-stop() {
-       [ -f $PID_F ] && kill $(cat $PID_F)
-}
diff --git a/net/miredo/files/miredo.init b/net/miredo/files/miredo.init
deleted file mode 100644 (file)
index 90e70c4..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
-START=50
-
-BIN=miredo
-DEFAULT=/etc/default/$BIN
-RUN_D=/var/run
-PID_F=$RUN_D/$BIN.pid
-
-start() {
-       [ -f $DEFAULT ] && . $DEFAULT
-       [ -d $RUN_D ] || mkdir -p $RUN_D
-       insmod ipv6
-       insmod tun
-       $BIN $OPTIONS
-}
-
-stop() {
-       [ -f $PID_F ] && kill $(cat $PID_F)
-}
diff --git a/net/miredo/patches/100-uclibc.patch b/net/miredo/patches/100-uclibc.patch
deleted file mode 100644 (file)
index 46573fe..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN miredo-1.1.6/libteredo/maintain.c miredo-1.1.6.new/libteredo/maintain.c
---- miredo-1.1.6/libteredo/maintain.c  2009-04-13 11:15:15.000000000 +0200
-+++ miredo-1.1.6.new/libteredo/maintain.c      2009-05-26 16:37:14.000000000 +0200
-@@ -59,7 +59,7 @@
- static inline void gettime (struct timespec *now)
- {
--#if (_POSIX_CLOCK_SELECTION - 0 >= 0) && (_POSIX_MONOTONIC_CLOCK - 0 >= 0)
-+#if (_POSIX_CLOCK_SELECTION - 0 >= 0) && (_POSIX_MONOTONIC_CLOCK - 0 >= 0) && !defined(__UCLIBC__)
-       if (clock_gettime (CLOCK_MONOTONIC, now) == 0)
-               return;
- #else