ucmb is not experimental anymore
authorMichael Büsch <mb@bu3sch.de>
Thu, 2 Apr 2009 09:41:11 +0000 (09:41 +0000)
committerMichael Büsch <mb@bu3sch.de>
Thu, 2 Apr 2009 09:41:11 +0000 (09:41 +0000)
SVN-Revision: 15078

utils/ucmb-tools/Makefile
utils/ucmb/Makefile

index d07d04c48ac85be6dc6a4f81931b9e75549ef301..527b7d3ca79495dae868634944abc5341f362515 100644 (file)
@@ -15,7 +15,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/ucmb-tools
   SECTION:=utils
   CATEGORY:=Utilities
 define Package/ucmb-tools
   SECTION:=utils
   CATEGORY:=Utilities
-  TITLE:=Microcontroller Message Bus tools (EXPERIMENTAL)
+  TITLE:=Microcontroller Message Bus tools
   DEPENDS:=+kmod-ucmb
 endef
 
   DEPENDS:=+kmod-ucmb
 endef
 
index 8bce64afd45e0e7c5e3514abb2ebd8fce05ae6a5..9828c69586cb8664f8b408bda64f48adbc3e279d 100644 (file)
@@ -18,7 +18,7 @@ define KernelPackage/ucmb
   DEPENDS:=@LINUX_2_6 +kmod-spi-gpio +kmod-crc16
   KCONFIG:=CONFIG_SPI=y \
           CONFIG_SPI_MASTER=y
   DEPENDS:=@LINUX_2_6 +kmod-spi-gpio +kmod-crc16
   KCONFIG:=CONFIG_SPI=y \
           CONFIG_SPI_MASTER=y
-  TITLE:=Microcontroller Message Bus (EXPERIMENTAL)
+  TITLE:=Microcontroller Message Bus
   FILES:=$(PKG_BUILD_DIR)/ucmb.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,93,ucmb)
 endef
   FILES:=$(PKG_BUILD_DIR)/ucmb.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,93,ucmb)
 endef
@@ -32,6 +32,8 @@ define KernelPackage/ucmb/description
        The device node considers every read/write to be one packet. The maximum packet
        size is either PAGE_SIZE (at least 4kb) or the microcontroller specific packet size
        limit, which is likely to be a lot smaller than PAGE_SIZE.
        The device node considers every read/write to be one packet. The maximum packet
        size is either PAGE_SIZE (at least 4kb) or the microcontroller specific packet size
        limit, which is likely to be a lot smaller than PAGE_SIZE.
+       To register an ucmb device, simply create a struct ucmb_platform_data
+       and register it via ucmb_device_register() from another kernel module.
        Example implementations for the microcontroller-side code can be found in
        the utils/ucmb/microcontroller_examples subdirectory of the OpenWRT packages feed.
 endef
        Example implementations for the microcontroller-side code can be found in
        the utils/ucmb/microcontroller_examples subdirectory of the OpenWRT packages feed.
 endef