[backfire] merge r23029, r23030, r23031 and r23032
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 12 Sep 2010 22:13:25 +0000 (22:13 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 12 Sep 2010 22:13:25 +0000 (22:13 +0000)
SVN-Revision: 23040

12 files changed:
include/package-defaults.mk
include/package-ipkg.mk
include/target.mk
package/opkg/Makefile
package/opkg/patches/011-old-config-location.patch
package/opkg/patches/014-add-force-run-hooks.patch [deleted file]
package/opkg/patches/014-force-postinstall.patch [new file with mode: 0644]
package/opkg/patches/015-add-arch-dest.patch [new file with mode: 0644]
rules.mk
scripts/metadata.pl
target/linux/adm5120/router_be/target.mk
target/linux/adm5120/router_le/target.mk

index ecc3af499fd27ce0a0c2533cba4003358eb65a91..1d29181528c545f726a32117404cdb820be72a6d 100644 (file)
@@ -23,10 +23,10 @@ define Package/Default
   else
     VERSION:=$(PKG_RELEASE)
   endif
-  ifneq ($(CONFIG_TARGET_adm5120),y)
-    PKGARCH:=$(BOARD)
+  ifneq ($(ARCH_PACKAGES),)
+    PKGARCH:=$(ARCH_PACKAGES)
   else
-    PKGARCH:=$(BOARD)_$(ARCH)
+    PKGARCH:=$(BOARD)
   endif
   PRIORITY:=optional
   DEFAULT:=
index 000bc719689c0069c53fb454e6513ddffd7a83e2..2a274032a72753504758cf130ce07d0657725221 100644 (file)
@@ -12,11 +12,13 @@ OPKG:= \
   IPKG_CONF_DIR=$(STAGING_DIR)/etc \
   IPKG_OFFLINE_ROOT=$(TARGET_DIR) \
   $(STAGING_DIR_HOST)/bin/opkg \
-       -f $(STAGING_DIR)/etc/opkg.conf \
        --offline-root $(TARGET_DIR) \
        --force-depends \
        --force-overwrite \
-       --force-run-hooks
+       --force-postinstall \
+       --add-dest root:/ \
+       --add-arch all:100 \
+       --add-arch $(ARCH_PACKAGES):200
 
 # invoke ipkg-build with some default options
 IPKG_BUILD:= \
@@ -81,7 +83,7 @@ ifeq ($(DUMP),)
        rm -rf $(STAGING_DIR_ROOT)/tmp-$(1)
        touch $$@
 
-    $$(IPKG_$(1)): $(STAGING_DIR)/etc/opkg.conf $(STAMP_BUILT)
+    $$(IPKG_$(1)): $(STAMP_BUILT)
        @rm -f $(PACKAGE_DIR)/$(1)_*
        rm -rf $$(IDIR_$(1))
        mkdir -p $$(IDIR_$(1))/CONTROL
@@ -125,11 +127,4 @@ ifeq ($(DUMP),)
     clean: $(1)-clean
 
   endef
-
-  $(STAGING_DIR)/etc/opkg.conf:
-       mkdir -p $(STAGING_DIR)/etc
-       ( echo "dest root /"                            > $@; \
-         echo "arch all 100"                           >> $@; \
-         echo "arch $(PKGARCH) 200"                    >> $@ )
-
 endif
index 5eb8547cc2ec5c8f0404490887e9f0dc2813d899..87efe5ade4d52dedcf3e68504dfc8d6fe602cbed 100644 (file)
@@ -183,6 +183,7 @@ define BuildTargets/DumpCurrent
         echo 'Target-Name: $(BOARDNAME)$(if $(SUBTARGETS),$(if $(SUBTARGET),))'; \
         echo 'Target-Path: $(subst $(TOPDIR)/,,$(PWD))'; \
         echo 'Target-Arch: $(ARCH)'; \
+        echo 'Target-Arch-Packages: $(if $(ARCH_PACKAGES),$(ARCH_PACKAGES),$(BOARD))'; \
         echo 'Target-Features: $(FEATURES)'; \
         echo 'Target-Depends: $(DEPENDS)'; \
         echo 'Target-Optimization: $(if $(CFLAGS),$(CFLAGS),$(DEFAULT_CFLAGS))'; \
index 45f8e6073875c9fe3c520fdd8e07d119abffa54c..5afd9935bb7bd3ba57f3bae37c3be099b520b195 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 PKG_NAME:=opkg
 PKG_REV:=513
 PKG_VERSION:=$(PKG_REV)
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_PROTO:=svn
 PKG_SOURCE_VERSION:=$(PKG_REV)
index 931f4f11648238a16316d021df5803630eed6303..4094713f3483925e788baf777d3a3011dc450635 100644 (file)
@@ -6,7 +6,7 @@
        }
 -    
 +
-+      if(!conf->conf_file)
++      if(!conf->conf_file && !conf->offline_root)
 +              conf->conf_file = xstrdup("/etc/opkg.conf");
 +
        if (parse_err)
diff --git a/package/opkg/patches/014-add-force-run-hooks.patch b/package/opkg/patches/014-add-force-run-hooks.patch
deleted file mode 100644 (file)
index cbf9de3..0000000
+++ /dev/null
@@ -1,68 +0,0 @@
---- a/libopkg/opkg_conf.c
-+++ b/libopkg/opkg_conf.c
-@@ -54,6 +54,7 @@ opkg_option_t options[] = {
-         { "force_reinstall", OPKG_OPT_TYPE_BOOL, &_conf.force_reinstall },
-         { "force_space", OPKG_OPT_TYPE_BOOL, &_conf.force_space },
-           { "check_signature", OPKG_OPT_TYPE_BOOL, &_conf.check_signature }, 
-+        { "force_run_hooks", OPKG_OPT_TYPE_BOOL, &_conf.force_run_hooks },
-         { "ftp_proxy", OPKG_OPT_TYPE_STRING, &_conf.ftp_proxy },
-         { "http_proxy", OPKG_OPT_TYPE_STRING, &_conf.http_proxy },
-         { "no_proxy", OPKG_OPT_TYPE_STRING, &_conf.no_proxy },
---- a/libopkg/opkg_conf.h
-+++ b/libopkg/opkg_conf.h
-@@ -73,6 +73,7 @@ struct opkg_conf
-      int force_space;
-      int force_removal_of_dependent_packages;
-      int force_removal_of_essential_packages;
-+     int force_run_hooks;
-      int check_signature;
-      int nodeps; /* do not follow dependencies */
-      char *offline_root;
---- a/libopkg/pkg.c
-+++ b/libopkg/pkg.c
-@@ -1249,7 +1249,7 @@ pkg_run_script(pkg_t *pkg, const char *s
-      /* XXX: FEATURE: When conf->offline_root is set, we should run the
-       maintainer script within a chroot environment. */
--     if (conf->offline_root) {
-+     if (conf->offline_root && !conf->force_run_hooks) {
-           opkg_msg(INFO, "Offline root mode: not running %s.%s.\n",
-                         pkg->name, script);
-         return 0;
---- a/src/opkg-cl.c
-+++ b/src/opkg-cl.c
-@@ -39,6 +39,7 @@ enum {
-       ARGS_OPT_FORCE_REMOVAL_OF_DEPENDENT_PACKAGES,
-       ARGS_OPT_FORCE_REMOVAL_OF_ESSENTIAL_PACKAGES,
-       ARGS_OPT_FORCE_SPACE,
-+      ARGS_OPT_FORCE_RUN_HOOKS,
-       ARGS_OPT_NOACTION,
-       ARGS_OPT_DOWNLOAD_ONLY,
-       ARGS_OPT_NODEPS,
-@@ -74,6 +75,8 @@ static struct option long_options[] = {
-               ARGS_OPT_FORCE_REMOVAL_OF_ESSENTIAL_PACKAGES},
-       {"force_removal_of_essential_packages", 0, 0,
-               ARGS_OPT_FORCE_REMOVAL_OF_ESSENTIAL_PACKAGES},
-+      {"force-run-hooks", 0, 0, ARGS_OPT_FORCE_RUN_HOOKS},
-+      {"force_run_hooks", 0, 0, ARGS_OPT_FORCE_RUN_HOOKS},
-       {"noaction", 0, 0, ARGS_OPT_NOACTION},
-       {"download-only", 0, 0, ARGS_OPT_DOWNLOAD_ONLY},
-       {"nodeps", 0, 0, ARGS_OPT_NODEPS},
-@@ -153,6 +156,9 @@ args_parse(int argc, char *argv[])
-               case ARGS_OPT_FORCE_SPACE:
-                       conf->force_space = 1;
-                       break;
-+              case ARGS_OPT_FORCE_RUN_HOOKS:
-+                      conf->force_run_hooks = 1;
-+                      break;
-               case ARGS_OPT_NODEPS:
-                       conf->nodeps = 1;
-                       break;
-@@ -242,6 +248,7 @@ usage()
-       printf("\t--force-overwrite     Overwrite files from other package(s)\n");
-       printf("\t--force-downgrade     Allow opkg to downgrade packages\n");
-       printf("\t--force-space         Disable free space checks\n");
-+      printf("\t--force-run-hooks     Run postinstall scripts even in offline mode\n");
-       printf("\t--noaction            No action -- test only\n");
-       printf("\t--download-only       No action -- download only\n");
-       printf("\t--nodeps              Do not follow dependencies\n");
diff --git a/package/opkg/patches/014-force-postinstall.patch b/package/opkg/patches/014-force-postinstall.patch
new file mode 100644 (file)
index 0000000..8634561
--- /dev/null
@@ -0,0 +1,68 @@
+--- a/libopkg/opkg_conf.c
++++ b/libopkg/opkg_conf.c
+@@ -54,6 +54,7 @@ opkg_option_t options[] = {
+         { "force_reinstall", OPKG_OPT_TYPE_BOOL, &_conf.force_reinstall },
+         { "force_space", OPKG_OPT_TYPE_BOOL, &_conf.force_space },
+           { "check_signature", OPKG_OPT_TYPE_BOOL, &_conf.check_signature }, 
++        { "force_postinstall", OPKG_OPT_TYPE_BOOL, &_conf.force_postinstall },
+         { "ftp_proxy", OPKG_OPT_TYPE_STRING, &_conf.ftp_proxy },
+         { "http_proxy", OPKG_OPT_TYPE_STRING, &_conf.http_proxy },
+         { "no_proxy", OPKG_OPT_TYPE_STRING, &_conf.no_proxy },
+--- a/libopkg/opkg_conf.h
++++ b/libopkg/opkg_conf.h
+@@ -73,6 +73,7 @@ struct opkg_conf
+      int force_space;
+      int force_removal_of_dependent_packages;
+      int force_removal_of_essential_packages;
++     int force_postinstall;
+      int check_signature;
+      int nodeps; /* do not follow dependencies */
+      char *offline_root;
+--- a/libopkg/pkg.c
++++ b/libopkg/pkg.c
+@@ -1249,7 +1249,7 @@ pkg_run_script(pkg_t *pkg, const char *s
+      /* XXX: FEATURE: When conf->offline_root is set, we should run the
+       maintainer script within a chroot environment. */
+-     if (conf->offline_root) {
++     if (conf->offline_root && !conf->force_postinstall) {
+           opkg_msg(INFO, "Offline root mode: not running %s.%s.\n",
+                         pkg->name, script);
+         return 0;
+--- a/src/opkg-cl.c
++++ b/src/opkg-cl.c
+@@ -39,6 +39,7 @@ enum {
+       ARGS_OPT_FORCE_REMOVAL_OF_DEPENDENT_PACKAGES,
+       ARGS_OPT_FORCE_REMOVAL_OF_ESSENTIAL_PACKAGES,
+       ARGS_OPT_FORCE_SPACE,
++      ARGS_OPT_FORCE_POSTINSTALL,
+       ARGS_OPT_NOACTION,
+       ARGS_OPT_DOWNLOAD_ONLY,
+       ARGS_OPT_NODEPS,
+@@ -74,6 +75,8 @@ static struct option long_options[] = {
+               ARGS_OPT_FORCE_REMOVAL_OF_ESSENTIAL_PACKAGES},
+       {"force_removal_of_essential_packages", 0, 0,
+               ARGS_OPT_FORCE_REMOVAL_OF_ESSENTIAL_PACKAGES},
++      {"force-postinstall", 0, 0, ARGS_OPT_FORCE_POSTINSTALL},
++      {"force_postinstall", 0, 0, ARGS_OPT_FORCE_POSTINSTALL},
+       {"noaction", 0, 0, ARGS_OPT_NOACTION},
+       {"download-only", 0, 0, ARGS_OPT_DOWNLOAD_ONLY},
+       {"nodeps", 0, 0, ARGS_OPT_NODEPS},
+@@ -153,6 +156,9 @@ args_parse(int argc, char *argv[])
+               case ARGS_OPT_FORCE_SPACE:
+                       conf->force_space = 1;
+                       break;
++              case ARGS_OPT_FORCE_POSTINSTALL:
++                      conf->force_postinstall = 1;
++                      break;
+               case ARGS_OPT_NODEPS:
+                       conf->nodeps = 1;
+                       break;
+@@ -242,6 +248,7 @@ usage()
+       printf("\t--force-overwrite     Overwrite files from other package(s)\n");
+       printf("\t--force-downgrade     Allow opkg to downgrade packages\n");
+       printf("\t--force-space         Disable free space checks\n");
++      printf("\t--force-postinstall   Run postinstall scripts even in offline mode\n");
+       printf("\t--noaction            No action -- test only\n");
+       printf("\t--download-only       No action -- download only\n");
+       printf("\t--nodeps              Do not follow dependencies\n");
diff --git a/package/opkg/patches/015-add-arch-dest.patch b/package/opkg/patches/015-add-arch-dest.patch
new file mode 100644 (file)
index 0000000..4730672
--- /dev/null
@@ -0,0 +1,238 @@
+--- a/libopkg/opkg.c
++++ b/libopkg/opkg.c
+@@ -120,6 +120,9 @@ opkg_new()
+       if (opkg_conf_init())
+               goto err0;
++      if (opkg_conf_load())
++              goto err0;
++
+       if (pkg_hash_load_feeds())
+               goto err1;
+--- a/libopkg/opkg_conf.c
++++ b/libopkg/opkg_conf.c
+@@ -91,15 +91,15 @@ opkg_option_t options[] = {
+ };
+ static int
+-resolve_pkg_dest_list(nv_pair_list_t *nv_pair_list)
++resolve_pkg_dest_list(void)
+ {
+      nv_pair_list_elt_t *iter;
+      nv_pair_t *nv_pair;
+      pkg_dest_t *dest;
+      char *root_dir;
+-     for (iter = nv_pair_list_first(nv_pair_list); iter;
+-                   iter = nv_pair_list_next(nv_pair_list, iter)) {
++     for (iter = nv_pair_list_first(&conf->tmp_dest_list); iter;
++                   iter = nv_pair_list_next(&conf->tmp_dest_list, iter)) {
+         nv_pair = (nv_pair_t *)iter->data;
+         if (conf->offline_root) {
+@@ -185,8 +185,7 @@ opkg_conf_set_option(const char *name, c
+ static int
+ opkg_conf_parse_file(const char *filename,
+-                              pkg_src_list_t *pkg_src_list,
+-                              nv_pair_list_t *tmp_dest_nv_pair_list)
++                              pkg_src_list_t *pkg_src_list)
+ {
+      int line_num = 0;
+      int err = 0;
+@@ -269,7 +268,7 @@ opkg_conf_parse_file(const char *filenam
+                               regmatch[11].rm_eo - regmatch[11].rm_so);
+         }
+-        /* We use the tmp_dest_nv_pair_list below instead of
++        /* We use the tmp_dest_list below instead of
+            conf->pkg_dest_list because we might encounter an
+            offline_root option later and that would invalidate the
+            directories we would have computed in
+@@ -292,7 +291,7 @@ opkg_conf_parse_file(const char *filenam
+                                  "Skipping.\n", name, value);
+              }
+         } else if (strcmp(type, "dest") == 0) {
+-             nv_pair_list_append(tmp_dest_nv_pair_list, name, value);
++             nv_pair_list_append(&conf->tmp_dest_list, name, value);
+         } else if (strcmp(type, "lists_dir") == 0) {
+              conf->lists_dir = xstrdup(value);
+         } else if (strcmp(type, "arch") == 0) {
+@@ -411,9 +410,19 @@ glob_errfunc(const char *epath, int eerr
+ int
+ opkg_conf_init(void)
+ {
++      pkg_src_list_init(&conf->pkg_src_list);
++      pkg_dest_list_init(&conf->pkg_dest_list);
++      pkg_dest_list_init(&conf->tmp_dest_list);
++      nv_pair_list_init(&conf->arch_list);
++
++      return 0;
++}
++
++int
++opkg_conf_load(void)
++{
+       int i, glob_ret;
+       char *tmp, *tmp_dir_base, **tmp_val;
+-      nv_pair_list_t tmp_dest_nv_pair_list;
+       glob_t globbuf;
+       char *etc_opkg_conf_pattern;
+@@ -423,11 +432,6 @@ opkg_conf_init(void)
+       conf->check_x509_path = 1;
+ #endif
+-      pkg_src_list_init(&conf->pkg_src_list);
+-      pkg_dest_list_init(&conf->pkg_dest_list);
+-      nv_pair_list_init(&conf->arch_list);
+-      nv_pair_list_init(&tmp_dest_nv_pair_list);
+-
+       if (!conf->offline_root)
+               conf->offline_root = xstrdup(getenv("OFFLINE_ROOT"));
+@@ -438,7 +442,7 @@ opkg_conf_init(void)
+                       goto err0;
+               }
+               if (opkg_conf_parse_file(conf->conf_file,
+-                              &conf->pkg_src_list, &tmp_dest_nv_pair_list))
++                              &conf->pkg_src_list))
+                       goto err1;
+       }
+@@ -467,7 +471,7 @@ opkg_conf_init(void)
+                                       !strcmp(conf->conf_file, globbuf.gl_pathv[i]))
+                               continue;
+               if ( opkg_conf_parse_file(globbuf.gl_pathv[i], 
+-                      &conf->pkg_src_list, &tmp_dest_nv_pair_list)<0) {
++                      &conf->pkg_src_list)<0) {
+                       globfree(&globbuf);
+                       goto err1;
+               }
+@@ -528,16 +532,16 @@ opkg_conf_init(void)
+       }
+       /* Even if there is no conf file, we'll need at least one dest. */
+-      if (nv_pair_list_empty(&tmp_dest_nv_pair_list)) {
+-      nv_pair_list_append(&tmp_dest_nv_pair_list,
++      if (nv_pair_list_empty(&conf->tmp_dest_list)) {
++      nv_pair_list_append(&conf->tmp_dest_list,
+                       OPKG_CONF_DEFAULT_DEST_NAME,
+                       OPKG_CONF_DEFAULT_DEST_ROOT_DIR);
+       }
+-      if (resolve_pkg_dest_list(&tmp_dest_nv_pair_list))
++      if (resolve_pkg_dest_list())
+               goto err5;
+-      nv_pair_list_deinit(&tmp_dest_nv_pair_list);
++      nv_pair_list_deinit(&conf->tmp_dest_list);
+       return 0;
+@@ -577,7 +581,7 @@ err1:
+               }
+       }
+ err0:
+-      nv_pair_list_deinit(&tmp_dest_nv_pair_list);
++      nv_pair_list_deinit(&conf->tmp_dest_list);
+       if (conf->dest_str)
+               free(conf->dest_str);
+       if (conf->conf_file)
+--- a/libopkg/opkg_conf.h
++++ b/libopkg/opkg_conf.h
+@@ -46,6 +46,7 @@ struct opkg_conf
+ {
+      pkg_src_list_t pkg_src_list;
+      pkg_dest_list_t pkg_dest_list;
++     pkg_dest_list_t tmp_dest_list;
+      nv_pair_list_t arch_list;
+      int restrict_to_default_dest;
+@@ -133,6 +134,7 @@ struct opkg_option {
+ };
+ int opkg_conf_init(void);
++int opkg_conf_load(void);
+ void opkg_conf_deinit(void);
+ int opkg_conf_write_status_files(void);
+--- a/src/opkg-cl.c
++++ b/src/opkg-cl.c
+@@ -40,6 +40,8 @@ enum {
+       ARGS_OPT_FORCE_REMOVAL_OF_ESSENTIAL_PACKAGES,
+       ARGS_OPT_FORCE_SPACE,
+       ARGS_OPT_FORCE_POSTINSTALL,
++      ARGS_OPT_ADD_ARCH,
++      ARGS_OPT_ADD_DEST,
+       ARGS_OPT_NOACTION,
+       ARGS_OPT_DOWNLOAD_ONLY,
+       ARGS_OPT_NODEPS,
+@@ -82,6 +84,8 @@ static struct option long_options[] = {
+       {"nodeps", 0, 0, ARGS_OPT_NODEPS},
+       {"offline", 1, 0, 'o'},
+       {"offline-root", 1, 0, 'o'},
++      {"add-arch", 1, 0, ARGS_OPT_ADD_ARCH},
++      {"add-dest", 1, 0, ARGS_OPT_ADD_DEST},
+       {"test", 0, 0, ARGS_OPT_NOACTION},
+       {"tmp-dir", 1, 0, 't'},
+       {"tmp_dir", 1, 0, 't'},
+@@ -96,6 +100,7 @@ args_parse(int argc, char *argv[])
+       int c;
+       int option_index = 0;
+       int parse_err = 0;
++      char *tuple, *prio;
+       while (1) {
+               c = getopt_long_only(argc, argv, "Ad:f:no:p:t:vV:",
+@@ -162,6 +167,21 @@ args_parse(int argc, char *argv[])
+               case ARGS_OPT_NODEPS:
+                       conf->nodeps = 1;
+                       break;
++              case ARGS_OPT_ADD_ARCH:
++              case ARGS_OPT_ADD_DEST:
++                      tuple = xstrdup(optarg);
++                      if ((prio = strchr(tuple, ':')) != NULL) {
++                              *prio++ = 0;
++                              if ((strlen(tuple) > 0) && (strlen(prio) > 0)) {
++                                      nv_pair_list_append(
++                                              (c == ARGS_OPT_ADD_ARCH)
++                                                      ? &conf->arch_list : &conf->tmp_dest_list,
++                                              tuple, prio
++                                      );
++                              }
++                      }
++                      free(tuple);
++                      break;
+               case ARGS_OPT_NOACTION:
+                       conf->noaction = 1;
+                       break;
+@@ -240,6 +260,8 @@ usage()
+       printf("                                directory name in a pinch).\n");
+       printf("\t-o <dir>              Use <dir> as the root directory for\n");
+       printf("\t--offline-root <dir>  offline installation of packages.\n");
++      printf("\t--add-arch <arch>:<prio>      Register architecture with given priority\n");
++      printf("\t--add-dest <name>:<path>      Register destination with given path\n");
+       printf("\nForce Options:\n");
+       printf("\t--force-depends               Install/remove despite failed dependencies\n");
+@@ -280,6 +302,9 @@ main(int argc, char *argv[])
+       int nocheckfordirorfile = 0;
+         int noreadfeedsfile = 0;
++      if (opkg_conf_init())
++              goto err0;
++
+       conf->verbosity = NOTICE;
+       opts = args_parse(argc, argv);
+@@ -317,7 +342,7 @@ main(int argc, char *argv[])
+       conf->pfm = cmd->pfm;
+-      if (opkg_conf_init())
++      if (opkg_conf_load())
+               goto err0;
+       if (!nocheckfordirorfile) {
index 0cb72ac6bcb8d36ace9ce0385f8385c8fcfc324d..5f82f6d80c7d7cc283c743c4b56ac0089e7f6079 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -30,6 +30,7 @@ strip_last=$(patsubst %.$(lastword $(subst .,$(space),$(1))),%,$(1))
 _SINGLE=export MAKEFLAGS=$(space);
 CFLAGS:=
 ARCH:=$(subst i486,i386,$(subst i586,i386,$(subst i686,i386,$(call qstrip,$(CONFIG_ARCH)))))
+ARCH_PACKAGES:=$(call qstrip,$(CONFIG_TARGET_ARCH_PACKAGES))
 BOARD:=$(call qstrip,$(CONFIG_TARGET_BOARD))
 TARGET_OPTIMIZATION:=$(call qstrip,$(CONFIG_TARGET_OPTIMIZATION))
 TARGET_SUFFIX=$(call qstrip,$(CONFIG_TARGET_SUFFIX))
index a0f0562716d2043174fabee63d8f4221fef333ec..ef8f8daeaa11be1ad46c043066827cff276a5149 100755 (executable)
@@ -49,6 +49,7 @@ sub parse_target_metadata() {
                /^Target-Name:\s*(.+)\s*$/ and $target->{name} = $1;
                /^Target-Path:\s*(.+)\s*$/ and $target->{path} = $1;
                /^Target-Arch:\s*(.+)\s*$/ and $target->{arch} = $1;
+               /^Target-Arch-Packages:\s*(.+)\s*$/ and $target->{arch_packages} = $1;
                /^Target-Features:\s*(.+)\s*$/ and $target->{features} = [ split(/\s+/, $1) ];
                /^Target-Depends:\s*(.+)\s*$/ and $target->{depends} = [ split(/\s+/, $1) ];
                /^Target-Description:/ and $target->{desc} = get_multiline(*FILE);
@@ -334,6 +335,15 @@ EOF
                $target->{subtarget} or print "\t\tdefault \"".$target->{board}."\" if TARGET_".$target->{conf}."\n";
        }
        print <<EOF;
+config TARGET_ARCH_PACKAGES
+       string
+       
+EOF
+       foreach my $target (@target) {
+               next if @{$target->{subtargets}} > 0;
+               print "\t\tdefault \"".($target->{arch_packages} || $target->{board})."\" if TARGET_".$target->{conf}."\n";
+       }
+       print <<EOF;
 
 config DEFAULT_TARGET_OPTIMIZATION
        string
index 2d326523e391ac9f779ab5eb32baa7d681b4963d..ab937f2c3d02856bc286d2326d86795d9ac1c859 100644 (file)
@@ -1,4 +1,5 @@
 ARCH:=mips
+ARCH_PACKAGES:=adm5120_mips
 SUBTARGET:=router_be
 BOARDNAME:=Big Endian
 FEATURES:=squashfs jffs2
index 40ff09e0a8c024c7709b7bb23da04122a22bb576..1d394e864dcc1fb40e88e4e77d43a1a8f9468d37 100644 (file)
@@ -1,4 +1,5 @@
 ARCH:=mipsel
+ARCH_PACKAGES:=adm5120_mipsel
 SUBTARGET:=router_le
 BOARDNAME:=Little Endian
 FEATURES:=squashfs jffs2 tgz