Fix gcc version selection
authorFelix Fietkau <nbd@openwrt.org>
Fri, 26 Jan 2007 11:02:59 +0000 (11:02 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 26 Jan 2007 11:02:59 +0000 (11:02 +0000)
- default version for linux 2.4 broken in r6208
- brcm-2.6 needs an older compiler at least on wgt634u (don't ask me why...)

SVN-Revision: 6209

toolchain/gcc/Config.in
toolchain/gcc/Config.version

index e5ee5bd..5ea51a8 100644 (file)
@@ -2,8 +2,8 @@
 
 choice
        prompt "GCC compiler Version" if TOOLCHAINOPTS
-       default GCC_VERSION_4_1_1
        default GCC_VERSION_3_4_6 if LINUX_2_4
+       default GCC_VERSION_4_1_1
        help
          Select the version of gcc you wish to use.
 
index 495c883..3ff5bbf 100644 (file)
@@ -12,11 +12,9 @@ config GCC_VERSION
        default "4.1.1"
 
 if !TOOLCHAINOPTS
-       config GCC_VERSION_4_2
-               default n
-
        config GCC_VERSION_3_4_6
                default y if LINUX_2_4
+               default y if LINUX_2_6_BRCM
 endif