[packages] add 'sslcat' package
authorNicolas Thill <nico@openwrt.org>
Tue, 23 Mar 2010 18:26:36 +0000 (18:26 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 23 Mar 2010 18:26:36 +0000 (18:26 +0000)
SVN-Revision: 20391

net/sslcat/Makefile [new file with mode: 0644]

diff --git a/net/sslcat/Makefile b/net/sslcat/Makefile
new file mode 100644 (file)
index 0000000..eb7fcc0
--- /dev/null
@@ -0,0 +1,43 @@
+# 
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=sslcat
+PKG_VERSION:=0.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME).tgz
+PKG_SOURCE_URL:=http://www.bindshell.net/tools/sslcat/
+PKG_MD5SUM:=27a88e2143cbfe216e13e9493bacd32e
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/sslcat
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=A netcat like utility with SSL support
+  URL:=http://www.bindshell.net/tools/sslcat
+  DEPENDS:= +libopenssl
+endef
+
+define Package/sslcat/description
+ SSLCat is a simple Unix utility that reads and writes data across an 
+ SSL enable network connection.
+endef
+
+CONFIGURE_ARGS+= \
+       --with-openssl=$(STAGING_DIR)/usr \
+
+define Package/sslcat/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/sslcat $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,sslcat))