Merge libbfd and binutils Makefile.
authorLars-Peter Clausen <lars@metafoo.de>
Tue, 13 Jan 2009 21:53:14 +0000 (21:53 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Tue, 13 Jan 2009 21:53:14 +0000 (21:53 +0000)
SVN-Revision: 14028

devel/binutils/Makefile
libs/libbfd/Makefile [deleted file]

index 99af8a30b7e44f466a50a6be219e98b0ee84c5c0..ea39f63e5031f63e9866d36ec28f0b682912838b 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -12,19 +12,17 @@ PKG_VERSION:=$(strip $(subst ",, $(CONFIG_BINUTILS_VERSION)))
 PKG_RELEASE:=1
 PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/binutils/ \
        ftp://gatekeeper.dec.com/pub/GNU/ \
-        ftp://ftp.uu.net/archive/systems/gnu/ \
-        ftp://ftp.eu.uu.net/pub/gnu/ \
-        ftp://ftp.funet.fi/pub/gnu/prep/ \
-        ftp://ftp.leo.org/pub/comp/os/unix/gnu/
+               ftp://ftp.uu.net/archive/systems/gnu/ \
+               ftp://ftp.eu.uu.net/pub/gnu/ \
+               ftp://ftp.funet.fi/pub/gnu/prep/ \
+               ftp://ftp.leo.org/pub/comp/os/unix/gnu/
 
 PKG_SOURCE:=binutils-$(PKG_VERSION).tar.bz2
 PATCH_DIR:=$(TOPDIR)/toolchain/binutils/patches/$(PKG_VERSION)
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-CONFIGURE_ARGS_XTRA+=--disable-werror \
-               --disable-nls
-
 define Package/binutils
   SECTION:=devel
   CATEGORY:=Development
@@ -36,20 +34,32 @@ define Package/binutils/description
   The Binutils package contains a linker, an assembler, and other tools for handling object files
 endef
 
+define Package/libbfd
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=libbfd
+endef
+
 define Build/Configure
-       (cd  $(PKG_BUILD_DIR)/; \
-               $(TARGET_CONFIGURE_OPTS) \
-               $(CONFIGURE_VARS) \
-               $(CONFIGURE_CMD) \
-               $(CONFIGURE_ARGS_XTRA) \
-               $(CONFIGURE_ARGS) \
-       );
+       $(call Build/Configure/Default, \
+               --disable-werror \
+               --disable-nls \
+       )
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/{lib,include}
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/libbfd.a \
+               $(1)/usr/lib/
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/include/{symcat,ansidecl,bfd,bfdlink}.h \
+               $(1)/usr/include/
 endef
 
 define Build/Compile
        make -C $(PKG_BUILD_DIR)/bfd/doc/ CFLAGS="-I$(PKG_BUILD_DIR)/include" chew
-       $(MAKE) -C $(PKG_BUILD_DIR) all
-       $(MAKE) -C $(PKG_BUILD_DIR) install DESTDIR=$(PKG_INSTALL_DIR)
+       $(call Build/Compile/Default)
 endef
 
 define Package/binutils/install
@@ -58,4 +68,9 @@ define Package/binutils/install
        $(CP) $(PKG_INSTALL_DIR)/usr/*-linux $(1)/usr
 endef
 
+define Package/libbdf/install
+    true
+endef
+
 $(eval $(call BuildPackage,binutils))
+$(eval $(call BuildPackage,libbfd))
diff --git a/libs/libbfd/Makefile b/libs/libbfd/Makefile
deleted file mode 100644 (file)
index a4f56ca..0000000
+++ /dev/null
@@ -1,61 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=binutils
-PKG_VERSION:=2.16.1
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.gnu.org/gnu/binutils
-PKG_MD5SUM:=6a9d529efb285071dad10e1f3d2b2967
-
-include $(INCLUDE_DIR)/package.mk
-
-TARGETS:=$(GNU_TARGET_NAME)
-
-define Package/libbfd
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=The Binutils BFD library
-  URL:=ftp://ftp.gnu.org/gnu/binutils
-endef
-
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-install-libbfd \
-               --enable-commonbfdlib \
-               --disable-nls \
-               --enable-targets="$(TARGETS)" \
-               , \
-               , \
-               bfd \
-       )
-endef
-
-TARGET_CFLAGS += $(FPIC)
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR)/bfd \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-define Build/InstallDev
-       mkdir -p $(1)/usr/include
-       $(CP)   $(PKG_INSTALL_DIR)/usr/include/ansidecl.h \
-               $(PKG_INSTALL_DIR)/usr/include/bfd{,link}.h \
-               $(PKG_INSTALL_DIR)/usr/include/symcat.h \
-               $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
-       $(CP)   $(PKG_INSTALL_DIR)/usr/lib/libbfd.a \
-               $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libbfd))