postgresql does not support spinlocks on avr32
authorFelix Fietkau <nbd@openwrt.org>
Tue, 5 Aug 2008 06:37:56 +0000 (06:37 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 5 Aug 2008 06:37:56 +0000 (06:37 +0000)
SVN-Revision: 12122

libs/postgresql/Makefile

index 8972651a21a1da9c5a0ca4c8b66b617012bbd4d6..43ceb651145168f5122b00ef3b1d31bb17dab7ce 100644 (file)
@@ -152,6 +152,7 @@ define Build/Configure
                        --without-tk \
                        --with-zlib="yes" \
                        --enable-depend \
+                       $(if $(CONFIG_TARGET_avr32),--disable-spinlocks) \
        );
        $(SED) 's@ECPG = ../../preproc/ecpg@ECPG = ../../preproc/ecpg.host@' $(PKG_BUILD_DIR)/src/interfaces/ecpg/test/Makefile.regress
        $(SED) 's@\./zic -d@./zic.host -d@' $(PKG_BUILD_DIR)/src/timezone/Makefile