[package] update pciutils to 3.1.4 (#5868)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 20 Sep 2009 13:23:45 +0000 (13:23 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 20 Sep 2009 13:23:45 +0000 (13:23 +0000)
SVN-Revision: 17648

utils/pciutils/Makefile
utils/pciutils/patches/100-remove-no-timestamping.patch

index 4160919d61f8c20f933323a9c9269243dbd95a9b..7db4f0c99f6328c50b563bc5c0015d56a4481641 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pciutils
-PKG_VERSION:=3.1.2
-PKG_RELEASE:=2
+PKG_VERSION:=3.1.4
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@KERNEL/software/utils/pciutils \
        ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci
-PKG_MD5SUM:=46387fd7a18c33fbb5311fdb3ab9ea12
+PKG_MD5SUM:=b38142c61c52f42d19540a0fcb11050a
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -52,9 +52,9 @@ endef
 
 define Package/pciutils/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/{lspci,setpci,update-pciids.sh} $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/{lspci,setpci,update-pciids.sh} $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/share
-       $(CP) $(PKG_BUILD_DIR)/pci.ids $(1)/usr/share/
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/pci.ids $(1)/usr/share/
 endef
 
 $(eval $(call BuildPackage,pciutils))
index f4423157485e41092a0329b80024f85c85a518fd..93bc85faf5ba96434796f40b4da482b25a8d626c 100644 (file)
@@ -1,7 +1,6 @@
-diff -Nur pciutils-3.1.2/update-pciids.sh pciutils-3.1.2-patched/update-pciids.sh
---- pciutils-3.1.2/update-pciids.sh    2008-11-11 01:11:51.000000000 +0200
-+++ pciutils-3.1.2-patched/update-pciids.sh    2009-04-27 01:34:24.000000000 +0300
-@@ -33,7 +33,7 @@
+--- a/update-pciids.sh
++++ b/update-pciids.sh
+@@ -33,7 +33,7 @@ if which curl >/dev/null 2>&1 ; then
        DL="curl -o $DEST.new $SRC"
      ${quiet} && DL="$DL -s -S"
  elif which wget >/dev/null 2>&1 ; then