packages: libs/savedynamic: Add missing Makefile.
authorDaniel Dickinson <crazycshore@gmail.com>
Wed, 5 May 2010 06:46:19 +0000 (06:46 +0000)
committerDaniel Dickinson <crazycshore@gmail.com>
Wed, 5 May 2010 06:46:19 +0000 (06:46 +0000)
SVN-Revision: 21370

libs/savedynamic/Makefile [new file with mode: 0644]

diff --git a/libs/savedynamic/Makefile b/libs/savedynamic/Makefile
new file mode 100644 (file)
index 0000000..521bf77
--- /dev/null
@@ -0,0 +1,52 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=savedynamic
+PKG_VERSION:=1.0
+PKG_RELEASE:=1
+MAINTAINER:=Daniel Dickinson <cshore@csolve.net>
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/savedynamic/Default
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=Preserve dynamic chains during firewall restart
+endef
+
+define Package/savedynamic
+  $(call Package/savedynamic/Default)
+  MENU:=1
+  DEPENDS:=+iptables-utils
+endef
+
+define Package/savedynamic/description
+    Uses iptables-save to save the option chain in option table (default filter)
+    as defined by the config section save in /etc/config/firewall.
+endef
+
+define Build/Prepare
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/block-extroot/install
+       $(INSTALL_DIR) $(1)/lib/firewall
+       $(INSTALL_DATA) ./files/savedynamic.sh $(1)/lib/firewall/
+endef
+
+$(eval $(call BuildPackage,savedynamic))
+