[packages] openswan: update to 2.6.28 (closes: #7544, #7725, #7782)
authorNicolas Thill <nico@openwrt.org>
Wed, 18 Aug 2010 08:10:45 +0000 (08:10 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 18 Aug 2010 08:10:45 +0000 (08:10 +0000)
SVN-Revision: 22693

net/openswan/Makefile
net/openswan/patches/110-scripts.patch
net/openswan/patches/120-no_manpages.patch
net/openswan/patches/130-compat_net_dev_ops.patch

index 86baa0637cf20f374e1e5734a2f322573cc0de92..0d270d3ed1801dd9fe315b5a7743c76520fa8283 100644 (file)
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=openswan
-PKG_VERSION:=2.6.25
+PKG_VERSION:=2.6.28
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.openswan.org/download
-PKG_MD5SUM:=c1223786c9eb58950a4be0ab2d0a84d1
+PKG_MD5SUM:=37f2ad2664dd89e6ad96ae82f6378166
 
 include $(INCLUDE_DIR)/package.mk
 
index bd0b049c930d5a410f813a0da31071046b21cf35..8af8a998fad2050fe577866dcd1e26a2590b5d29 100644 (file)
                then
                        echo Cannot write to directory to create \"$stderrlog\".
                        exit 1
---- a/programs/_realsetup/_realsetup.in
-+++ b/programs/_realsetup/_realsetup.in
-@@ -282,7 +282,7 @@ case "$1" in
-       # misc pre-Pluto setup
--      perform test -d `dirname $subsyslock` "&&" touch $subsyslock
-+      perform test -d `echo $subsyslock | sed -r 's/(^.*\/)(.*$)/\1/'` "&&" touch $subsyslock "&&" rm -f $subsyslock
-       manualconns
index b3d31cf378a528dcbc44d8cd670a2eb6a8956147..0ce520c55a89bfe74cccec2e100a904e60d91cfb 100644 (file)
@@ -22,7 +22,7 @@
 -
 --- a/programs/pluto/Makefile
 +++ b/programs/pluto/Makefile
-@@ -188,35 +188,11 @@ doinstall: all
+@@ -191,35 +191,11 @@ doinstall: all
        $(INSTALL) $(INSTBINFLAGS) $(BINNAMEPLUTO) $(BINNAMEWHACK) $(LIBEXECDIR)
        #$(INSTALL) $(INSTSUIDFLAGS) $(BINNAMEWHACKINIT) $(LIBEXECDIR)
        if $(USE_ADNS) ; then $(INSTALL) $(INSTBINFLAGS) $(BINNAMEADNS)  $(LIBEXECDIR) ; fi
index 97cb853b03592bafff6388c91f2486011fa78da9..e87b955dfcd5754cae5450f3db0025285a62b51b 100644 (file)
@@ -1,7 +1,7 @@
 --- a/linux/include/openswan/ipsec_kversion.h
 +++ b/linux/include/openswan/ipsec_kversion.h
-@@ -351,6 +351,12 @@
- # define HAVE_CURRENT_UID
+@@ -363,6 +363,12 @@
+ #endif
  #endif
  
 +#if LINUX_VERSION_CODE == KERNEL_VERSION(2,6,30)
@@ -11,5 +11,5 @@
 +#endif
 +
  #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,31)
- # define HAVE_SKB_DST 1
- #endif
+ # define USE_NETDEV_OPS
+ #else