enable and use shadow passwords by default
authorImre Kaloz <kaloz@openwrt.org>
Thu, 10 Nov 2011 12:55:01 +0000 (12:55 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Thu, 10 Nov 2011 12:55:01 +0000 (12:55 +0000)
SVN-Revision: 28936

package/base-files/Makefile
package/busybox/Makefile
package/busybox/config/loginutils/Config.in

index 6e41f0458935c125d56fd12e83b201d440005508..da9e6f3727296e795783262543ce93e3e4ad382c 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=91
+PKG_RELEASE:=92
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
@@ -455,10 +455,9 @@ define Package/base-files/install
        )
 # Form valid /etc/shadow entries, by copying the user:pw pairs
 # from /etc/passwd, and adding on pw change data
-       $(if $(CONFIG_BUSYBOX_CONFIG_FEATURE_SHADOWPASSWDS), \
-               cut -d ':' -f 1-2 $(1)/etc/passwd > $(1)/etc/shadow; \
-               $(SED) 's/$$$$/:13848:0:99999:7:::/' $(1)/etc/shadow \
-       )
+       cut -d ':' -f 1-2 $(1)/etc/passwd > $(1)/etc/shadow; \
+       $(SED) 's/$$$$/:0:0:99999:7:::/' $(1)/etc/shadow
+
        $(SED) 's,$$$$R,$(REVISION),g' $(1)/etc/banner
        mkdir -p $(1)/CONTROL
        mkdir -p $(1)/dev
index 871eae4ad31a8d696a9bac8701555ec7354cd6d3..967fa75dd147e499afe8ca16c5644fd11a7c7f1a 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.19.3
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 94bf32ba4ff3a326a9b8a11e815156f66e61d242..8c32851a2bdf9d2b160329aba7452aafbe0bca1f 100644 (file)
@@ -20,7 +20,7 @@ config BUSYBOX_CONFIG_REMOVE_SHELL
 
 config BUSYBOX_CONFIG_FEATURE_SHADOWPASSWDS
        bool "Support for shadow passwords"
-       default n
+       default y
        help
          Build support for shadow password in /etc/shadow. This file is only
          readable by root and thus the encrypted passwords are no longer