jtg: fix compile on platforms with VFP
authorFlorian Fainelli <florian@openwrt.org>
Tue, 20 May 2014 04:51:27 +0000 (04:51 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 20 May 2014 04:51:27 +0000 (04:51 +0000)
buildbot reported error on platforms with VFP (sunxi,imx6,omap):
ld: error: jtg uses VFP register arguments, /tmp/ccewx1gu.o does not

CFLAGS were overwritten so append them instead

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 40788

net/jtg/patches/001-Makefile_honor_CFLAGS_for_VFP.patch [new file with mode: 0644]

diff --git a/net/jtg/patches/001-Makefile_honor_CFLAGS_for_VFP.patch b/net/jtg/patches/001-Makefile_honor_CFLAGS_for_VFP.patch
new file mode 100644 (file)
index 0000000..11e4d6c
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -2,7 +2,7 @@ BINDIR= $(HOME)/bin
+ VERSION=1.95
+ CC = gcc
+-CFLAGS= -O3 -Wall -Winline -pedantic
++CFLAGS+= -O3 -Wall -Winline -pedantic
+ CFLAGS+= -g
+ # The "-DLinuxTCP" controls which TCP options are in use