kernel: update kernel to version 2.6.39.4
authorHauke Mehrtens <hauke@hauke-m.de>
Tue, 16 Aug 2011 22:04:10 +0000 (22:04 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 16 Aug 2011 22:04:10 +0000 (22:04 +0000)
SVN-Revision: 28022

12 files changed:
include/kernel-version.mk
target/linux/ar71xx/Makefile
target/linux/au1000/Makefile
target/linux/avr32/Makefile
target/linux/brcm63xx/Makefile
target/linux/cns3xxx/Makefile
target/linux/cobalt/Makefile
target/linux/ep93xx/Makefile
target/linux/generic/patches-2.6.39/630-packet_socket_type.patch
target/linux/generic/patches-2.6.39/642-bridge_port_isolate.patch
target/linux/lantiq/Makefile
target/linux/ramips/Makefile

index 6161d122fd267234a383b082c76ed322a318d08c..530fae283b367001d628990ef94fc1b2df5c6288 100644 (file)
@@ -26,8 +26,8 @@ endif
 ifeq ($(LINUX_VERSION),2.6.38.8)
   LINUX_KERNEL_MD5SUM:=d27b85795c6bc56b5a38d7d31bf1d724
 endif
-ifeq ($(LINUX_VERSION),2.6.39.2)
-  LINUX_KERNEL_MD5SUM:=51be93d92028658ec93f68b79a378b17
+ifeq ($(LINUX_VERSION),2.6.39.4)
+  LINUX_KERNEL_MD5SUM:=a17c748c2070168f1e784e9605ca043d
 endif
 ifeq ($(LINUX_VERSION),3.0.1)
   LINUX_KERNEL_MD5SUM:=aed949984b878b7fb77ffe9cbee8ce0c
index d02504b618e4a9172ea0f30ae23f59eb937403f8..0925d9c3c2dccd05e71b8169cbc4d5a05f70163f 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=2.6.39.2
+LINUX_VERSION:=2.6.39.4
 
 include $(INCLUDE_DIR)/target.mk
 
index 6e6169768cf99bfdcaeaaff28f61fd88287064e4..92de1206d1ba56bd08f3960b3e9dcc3a6f99e289 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=jffs2 usb pci
 SUBTARGETS=au1500 au1550
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=2.6.39.2
+LINUX_VERSION:=2.6.39.4
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini yamonenv
index 01aeea1fa92b5a62bfedb7572c204c1033efcffe..5729570507565515e8b5cd0764eee7dd0996ab29 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.39.2
+LINUX_VERSION:=2.6.39.4
 
 include $(INCLUDE_DIR)/target.mk
 
index 18a2ce80f3374233a523d4d9b47b498ab36468f9..33c0268787a89d4e21119802d8fb61cb4bd493b0 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=2.6.39.2
+LINUX_VERSION:=2.6.39.4
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index 4d02c5c22b3804655fad2ddd85a42110e6b07bcb..e2297a64784b4314ab3a8f1da50217cb1737c34b 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs fpu gpio
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.39.2
+LINUX_VERSION:=2.6.39.4
 
 include $(INCLUDE_DIR)/target.mk
 
index dbcf61e22447a8ab8d198f5ab0647a4c24be3272..b0de847411ac1782214cc25905cce2e6331ed6d9 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=targz pci ext4
 CFLAGS:=-O2 -pipe -mtune=r5000 -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=2.6.39.2
+LINUX_VERSION:=2.6.39.4
 
 include $(INCLUDE_DIR)/target.mk
 
index 1634c808157fcb641ffc5bf4629acea24c767c31..b7da8a0818e0eb201ca230f8e137df53fee9f5a1 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 ext4 targz usb
 CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=2.6.39.2
+LINUX_VERSION:=2.6.39.4
 
 include $(INCLUDE_DIR)/target.mk
 
index 75b61290c340b6801c07579863e3328d0a7939ee..122a108048a0172778a17dbb326e997fee55d1bb 100644 (file)
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -1523,6 +1526,7 @@ static int packet_create(struct net *net
+@@ -1524,6 +1527,7 @@ static int packet_create(struct net *net
        spin_lock_init(&po->bind_lock);
        mutex_init(&po->pg_vec_lock);
        po->prot_hook.func = packet_rcv;
@@ -99,7 +99,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
  
        if (sock->type == SOCK_PACKET)
                po->prot_hook.func = packet_rcv_spkt;
-@@ -2091,6 +2095,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -2093,6 +2097,16 @@ packet_setsockopt(struct socket *sock, i
                po->tp_tstamp = val;
                return 0;
        }
@@ -116,7 +116,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        default:
                return -ENOPROTOOPT;
        }
-@@ -2148,6 +2162,13 @@ static int packet_getsockopt(struct sock
+@@ -2150,6 +2164,13 @@ static int packet_getsockopt(struct sock
  
                data = &val;
                break;
index c051a29f2d2192cd30d7ff8f97eed923f0c6efca..09a3b913d040fd29950650a5f3b8b22ade7348c2 100644 (file)
@@ -1,6 +1,6 @@
 --- a/net/bridge/br_private.h
 +++ b/net/bridge/br_private.h
-@@ -132,6 +132,7 @@ struct net_bridge_port
+@@ -133,6 +133,7 @@ struct net_bridge_port
  
        unsigned long                   flags;
  #define BR_HAIRPIN_MODE               0x00000001
index 82e5c3926a51e0eb09d220f0d6e5f04dcf8f3937..e355c15730ac0c480160a806fbe2a6ccd85ef12b 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Lantiq GPON/XWAY
 FEATURES:=squashfs jffs2
 DEFAULT_SUBTARGET:=danube
 
-LINUX_VERSION:=2.6.39.2
+LINUX_VERSION:=2.6.39.4
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
 
index 96d19ce1984070d3239b6a0be049291dfb6a209c..012fc5620e7c3c36576e3047602f3071b34c28c6 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.39.2
+LINUX_VERSION:=2.6.39.4
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\