[package] add cryptsetup, patch from Jan Willies
authorFlorian Fainelli <florian@openwrt.org>
Sat, 20 Mar 2010 12:16:06 +0000 (12:16 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 20 Mar 2010 12:16:06 +0000 (12:16 +0000)
SVN-Revision: 20320

utils/cryptsetup/Makefile [new file with mode: 0644]

diff --git a/utils/cryptsetup/Makefile b/utils/cryptsetup/Makefile
new file mode 100644 (file)
index 0000000..17006d9
--- /dev/null
@@ -0,0 +1,50 @@
+#
+# Copyright (C) 2006-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=cryptsetup
+PKG_VERSION:=1.1.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://cryptsetup.googlecode.com/files/
+PKG_MD5SUM:=8177f1833f4d6aaacc5812046d2010b6
+
+include $(INCLUDE_DIR)/package.mk
+
+TARGET_LDFLAGS+=-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+
+define Package/cryptsetup/Default
+  URL:=http://cryptsetup.googlecode.com/files/
+endef
+
+define Package/cryptsetup
+$(call Package/cryptsetup/Default)
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=Cryptsetup
+  DEPENDS:=+libblkid +libuuid +libpopt +lvm2 +libgcrypt
+endef
+
+define Package/cryptsetup/description
+       Cryptsetup-luks
+endef
+
+define Build/Compile
+       $(call Build/Configure/Default)
+       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
+endef
+
+define Package/cryptsetup/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/cryptsetup $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcryptsetup.so.* $(1)/usr/lib
+endef
+
+$(eval $(call BuildPackage,cryptsetup))