packages: shflags: Fix getting sources
authorGabor Juhos <juhosg@openwrt.org>
Sun, 20 Oct 2013 15:58:26 +0000 (15:58 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 20 Oct 2013 15:58:26 +0000 (15:58 +0000)
Freecwmp does not export a git repository for shflags anymore. This fix
makes OpenWrt get the sources directly from the svn repository of the
shflags googlecode project.

Signed-off-by: Diego López Recas <sueltalo@gmail.com>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 38480

libs/shflags/Makefile
libs/shflags/patches/000-strip.patch

index 5f1c754115a6f0b286d6355cee239296fd5adf94..3af741cc544cff9f9505eef6d7410d631161d7e7 100644 (file)
@@ -8,14 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=shflags
-PKG_VERSION:=2012-06-11
-PKG_RELEASE=$(PKG_SOURCE_VERSION)
+PKG_REV:=133
+PKG_VERSION:=2012-06-11_r$(PKG_REV)
+PKG_RELEASE=1.0.x
 
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=git://dev.freecwmp.org/shflags-clone/
+PKG_SOURCE_PROTO:=svn
+PKG_SOURCE_URL:=http://shflags.googlecode.com/svn/trunk
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=4411ea9115802b86ffee68a2cbbbbf143dfeebbd
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 
 include $(INCLUDE_DIR)/package.mk
 
index bc059484e1ef903e2771ac471f4d592978c649ce..cb4275e3da6e042123956e609cf887c57114655d 100644 (file)
@@ -1,7 +1,7 @@
 --- a/source/1.0/src/shflags
 +++ b/source/1.0/src/shflags
 @@ -1,91 +1,10 @@
--# $Id$
+-# $Id: shflags 132 2009-05-10 18:03:58Z kate.ward@forestent.com $
 -# vim:et:ft=sh:sts=2:sw=2
 -#
 -# Copyright 2008 Kate Ward. All Rights Reserved.