libdlna: Fix parallel build
authorMichael Büsch <mb@bu3sch.de>
Fri, 8 Oct 2010 17:57:18 +0000 (17:57 +0000)
committerMichael Büsch <mb@bu3sch.de>
Fri, 8 Oct 2010 17:57:18 +0000 (17:57 +0000)
SVN-Revision: 23330

libs/libdlna/Makefile
libs/libdlna/patches/200-parallel-build.patch [new file with mode: 0644]

index 1b333d4ddadcbde29a0da907d7b664fe368cbc07..496f22c5243548343cd9e0be8c6163d419c28a31 100644 (file)
@@ -15,6 +15,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://libdlna.geexbox.org/releases/
 PKG_MD5SUM:=2c974f95b711e5fd07f78fc4ebfcca66
 
 PKG_SOURCE_URL:=http://libdlna.geexbox.org/releases/
 PKG_MD5SUM:=2c974f95b711e5fd07f78fc4ebfcca66
 
+PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
diff --git a/libs/libdlna/patches/200-parallel-build.patch b/libs/libdlna/patches/200-parallel-build.patch
new file mode 100644 (file)
index 0000000..7f9934b
--- /dev/null
@@ -0,0 +1,17 @@
+---
+ Makefile |    4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+--- libdlna-0.2.3.orig/Makefile
++++ libdlna-0.2.3/Makefile
+@@ -32,8 +32,8 @@ lib:
+ test: $(LIBTEST)
+-$(LIBTEST): $(SRCS)
+-      $(CC) $? $(OPTFLAGS) $(CFLAGS) $(LDFLAGS) -o $@
++$(LIBTEST): lib $(SRCS)
++      $(CC) $(SRCS) $(OPTFLAGS) $(CFLAGS) $(LDFLAGS) -o $@
+ clean:
+       $(MAKE) -C src clean