override cflags (not honored by ./configure)
authorNicolas Thill <nico@openwrt.org>
Wed, 4 Oct 2006 17:13:24 +0000 (17:13 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 4 Oct 2006 17:13:24 +0000 (17:13 +0000)
SVN-Revision: 4910

libs/libnet-1.0.x/Makefile

index 2161e5ef7a3333fc045faef73b6e0fd6c4d3b4e3..9a125200cdb55397001795756f7a33e15d98104b 100644 (file)
@@ -55,7 +55,9 @@ define Build/Configure
 endef
 
 define Build/Compile
+       # pass CFLAGS again to override -O2 set by configure
        $(MAKE) -C $(PKG_BUILD_DIR) \
+               CFLAGS="$(TARGET_CFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef