add tcptraceroute (closes: #1490)
authorNicolas Thill <nico@openwrt.org>
Mon, 26 Mar 2007 03:08:22 +0000 (03:08 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 26 Mar 2007 03:08:22 +0000 (03:08 +0000)
SVN-Revision: 6704

net/tcptraceroute/Makefile [new file with mode: 0644]
net/tcptraceroute/patches/001-configure_cross_compile.patch [new file with mode: 0644]

diff --git a/net/tcptraceroute/Makefile b/net/tcptraceroute/Makefile
new file mode 100644 (file)
index 0000000..d7531cc
--- /dev/null
@@ -0,0 +1,50 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=tcptraceroute
+PKG_VERSION:=1.5beta7
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://michael.toren.net/code/tcptraceroute
+PKG_MD5SUM:=65d1001509f971ea986fcbc2dd009643
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/tcptraceroute
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libpcap +libnet1
+  TITLE:=A traceroute implementation using TCP packets.
+  URL:=http://michael.toren.net/code/tcptraceroute/
+endef
+
+define Build/Configure
+        $(call Build/Configure/Default, \
+               , \
+               CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/lib/libnet-1.1.x/include" \
+               LDFLAGS="$$$$LDFLAGS -L$(STAGING_DIR)/usr/lib/libnet-1.1.x/lib" \
+               PATH="$(STAGING_DIR)/usr/lib/libnet-1.1.x/bin:$$$$PATH" \
+        )
+endef
+
+define Build/Compile   
+       $(MAKE) -C $(PKG_BUILD_DIR)
+endef
+
+define Package/tcptraceroute/install   
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/tcptraceroute $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,tcptraceroute))
diff --git a/net/tcptraceroute/patches/001-configure_cross_compile.patch b/net/tcptraceroute/patches/001-configure_cross_compile.patch
new file mode 100644 (file)
index 0000000..5690a23
--- /dev/null
@@ -0,0 +1,62 @@
+--- tcptraceroute-1.5beta7.orig/configure      2006-03-29 02:49:55.000000000 +0100
++++ tcptraceroute-1.5beta7/configure   2007-03-19 19:13:31.644193395 +0000
+@@ -5484,11 +5484,11 @@
+ echo "$as_me:$LINENO: checking for Solaris" >&5
+ echo $ECHO_N "checking for Solaris... $ECHO_C" >&6
+ if test "$cross_compiling" = yes; then
+-  { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
++  { { echo "$as_me:$LINENO: warning: cannot run test program while cross compiling
+ See \`config.log' for more details." >&5
+-echo "$as_me: error: cannot run test program while cross compiling
++echo "$as_me: warning: cannot run test program while cross compiling
+ See \`config.log' for more details." >&2;}
+-   { (exit 1); exit 1; }; }
++   }
+ else
+   cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h.  */
+@@ -5551,11 +5551,11 @@
+ echo "$as_me:$LINENO: checking for BSDI" >&5
+ echo $ECHO_N "checking for BSDI... $ECHO_C" >&6
+ if test "$cross_compiling" = yes; then
+-  { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
++  { { echo "$as_me:$LINENO: warning: cannot run test program while cross compiling
+ See \`config.log' for more details." >&5
+-echo "$as_me: error: cannot run test program while cross compiling
++echo "$as_me: warning: cannot run test program while cross compiling
+ See \`config.log' for more details." >&2;}
+-   { (exit 1); exit 1; }; }
++   }
+ else
+   cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h.  */
+@@ -5618,11 +5618,11 @@
+ echo "$as_me:$LINENO: checking for NetBSD" >&5
+ echo $ECHO_N "checking for NetBSD... $ECHO_C" >&6
+ if test "$cross_compiling" = yes; then
+-  { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
++  { { echo "$as_me:$LINENO: warning: cannot run test program while cross compiling
+ See \`config.log' for more details." >&5
+-echo "$as_me: error: cannot run test program while cross compiling
++echo "$as_me: warning: cannot run test program while cross compiling
+ See \`config.log' for more details." >&2;}
+-   { (exit 1); exit 1; }; }
++   }
+ else
+   cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h.  */
+@@ -5685,11 +5685,11 @@
+ echo "$as_me:$LINENO: checking for MacOS X" >&5
+ echo $ECHO_N "checking for MacOS X... $ECHO_C" >&6
+ if test "$cross_compiling" = yes; then
+-  { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
++  { { echo "$as_me:$LINENO: warning: cannot run test program while cross compiling
+ See \`config.log' for more details." >&5
+-echo "$as_me: error: cannot run test program while cross compiling
++echo "$as_me: warning: cannot run test program while cross compiling
+ See \`config.log' for more details." >&2;}
+-   { (exit 1); exit 1; }; }
++   }
+ else
+   cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h.  */