ipq806x: add db149 support to OpenWrt init scripts
authorJohn Crispin <john@openwrt.org>
Tue, 21 Apr 2015 07:15:47 +0000 (07:15 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 21 Apr 2015 07:15:47 +0000 (07:15 +0000)
DB149 is a IPQ8064 based platform. This patch adds the init scripts to
detect it, configure the network accordingly, and generate a flashable
image for it.

Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org>
SVN-Revision: 45537

target/linux/ipq806x/base-files/etc/uci-defaults/network
target/linux/ipq806x/base-files/lib/ipq806x.sh
target/linux/ipq806x/image/Makefile

index 34e9fe482b458f9c0767b2dd74fee52ade74f2e2..354cea9e3d9a1deabc1cac627a093c606d642aba 100755 (executable)
@@ -22,6 +22,12 @@ ap148)
        ucidef_add_switch_vlan "switch0" "1" "6 1 2 3 4"
        ucidef_add_switch_vlan "switch0" "2" "0 5"
        ;;
+db149)
+       ucidef_set_interfaces_lan_wan "eth1 eth2 eth3" "eth0"
+       ucidef_add_switch "switch0" "1" "1"
+       ucidef_add_switch_vlan "switch0" "1" "6 1 2 3 4"
+       ucidef_add_switch_vlan "switch0" "2" "0 5"
+       ;;
 *)
        echo "Unsupported hardware. Network interfaces not intialized"
        ;;
index 7c47fa2a8565f7bd3809c4095e4d4b184d8a8926..2790f3f38651d1783f37bd51bfbf304189fe40a1 100644 (file)
@@ -17,6 +17,9 @@ ipq806x_board_detect() {
        *"AP148")
                name="ap148"
                ;;
+       *"DB149")
+               name="db149"
+               ;;
        esac
 
        [ -z "$name" ] && name="unknown"
index 77d191f9a9a2753f6db7d5629886e82dd95fa480..e2346e63198a3a16aba7108dcbf068f8926e7511 100644 (file)
@@ -22,6 +22,7 @@ endef
 define Image/BuildKernel
        $(CP) $(LINUX_DIR)/vmlinux $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf
        $(call Image/BuildKernel/FIT,qcom-ipq8064-ap148)
+       $(call Image/BuildKernel/FIT,qcom-ipq8064-db149)
 endef
 
 define Image/Build/squashfs