fix bmon
authorNicolas Thill <nico@openwrt.org>
Mon, 9 Oct 2006 21:21:18 +0000 (21:21 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 9 Oct 2006 21:21:18 +0000 (21:21 +0000)
SVN-Revision: 5007

net/bmon/Makefile
net/bmon/patches/01-bugfixes.patch [new file with mode: 0644]

index 1e0d75dec6721587c0592c9208cf2c57c3fceb15..06e8509cd905006b9573834d39ef4bedddd5078f 100644 (file)
@@ -3,7 +3,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 4603 2006-08-18 21:21:06Z mbm $
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -27,29 +27,31 @@ define Package/bmon
   DEPENDS:=+libncurses
   TITLE:=bmon is a portable bandwidth monitor
   DESCRIPTION:=\
-       bmon is a portable bandwidth monitor\\\
-       and rate estimator running on various\\\
-       operating systems. It supports various\\\
+       bmon is a portable bandwidth monitor \\\
+       and rate estimator running on various \\\
+       operating systems. It supports various \\\
        input methods for different architectures.
   URL:=http://people.suug.ch/~tgr/bmon/
 endef
 
 define Build/Configure
        $(call Build/Configure/Default, \
-               --disable-cnt-workaroun \
+               --disable-cnt-workaround \
+               --disable-dbi \
                --disable-rrd \
-               --disable-asoun \
+               --disable-asound \
        )
 endef
 
 
 define Build/Compile
-$(call Build/Compile/Default,all)
+       $(call Build/Compile/Default,all)
 endef
 
 define Package/bmon/install
        install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/src/bmon $(1)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/src/bmon $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,bmon))
+
diff --git a/net/bmon/patches/01-bugfixes.patch b/net/bmon/patches/01-bugfixes.patch
new file mode 100644 (file)
index 0000000..3657058
--- /dev/null
@@ -0,0 +1,24 @@
+diff -ruN bmon-2.1.0-old/src/out_audio.c bmon-2.1.0-new/src/out_audio.c
+--- bmon-2.1.0-old/src/out_audio.c     2005-04-05 17:01:33.000000000 +0200
++++ bmon-2.1.0-new/src/out_audio.c     2006-10-09 23:11:44.000000000 +0200
+@@ -141,7 +141,7 @@
+       .om_draw = audio_draw,
+       .om_set_opts = audio_set_opts,
+       .om_probe = audio_probe,
+-      .om_shutdown audio_shutdown,
++      .om_shutdown = audio_shutdown,
+ };
+ static void __init audio_init(void)
+diff -ruN bmon-2.1.0-old/src/out_xml_event.c bmon-2.1.0-new/src/out_xml_event.c
+--- bmon-2.1.0-old/src/out_xml_event.c 2005-04-05 17:01:33.000000000 +0200
++++ bmon-2.1.0-new/src/out_xml_event.c 2006-10-09 23:11:59.000000000 +0200
+@@ -127,7 +127,7 @@
+       .om_draw = xml_event_draw,
+       .om_set_opts = xml_event_set_opts,
+       .om_probe = xml_event_probe,
+-      .om_shutdown xml_event_shutdown,
++      .om_shutdown = xml_event_shutdown,
+ };
+ static void __init xml_event_init(void)