[packages] libgpg-error: update to 1.9
authorStephen Walker <stephendwalker@gmail.com>
Sun, 17 Jul 2011 18:05:53 +0000 (18:05 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Sun, 17 Jul 2011 18:05:53 +0000 (18:05 +0000)
 * Signed-off-by: Your Joe Roback <openwrt-devel at roback.cc>
 * enable parallel building
 * remove dead mirrors
 * use CONFIGURE_ARGS

SVN-Revision: 27658

libs/libgpg-error/Makefile

index 77f8835fb883e0d2ef7d21d82622c9d28cc2ab9d..f60a9721a390d8d0f805371d1f1e35ca3a01d8fd 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2005-2009 OpenWrt.org
+# Copyright (C) 2005-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,22 +8,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libgpg-error
-PKG_VERSION:=1.7
+PKG_VERSION:=1.9
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.gnupg.org/gcrypt/libgpg-error/ \
-       http://mirrors.rootmode.com/ftp.gnupg.org/libgpg-error/ \
-       http://gulus.usherbrooke.ca/pub/appl/GnuPG/libgpg-error/ \
-       http://gnupg.unixmexico.org/ftp/libgpg-error/
-PKG_MD5SUM:=62c0d09d1e76c5b6da8fff92314c4665
+PKG_SOURCE_URL:=ftp://ftp.gnupg.org/gcrypt/libgpg-error
+PKG_MD5SUM:=521b98aa9395e7eaf0ef2236233a0796
 
+PKG_BUILD_PARALLEL:=1
 PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-PKG_INSTALL=1
-
 define Package/libgpg-error
   SECTION:=libs
   CATEGORY:=Libraries
@@ -33,21 +30,18 @@ endef
 
 define Package/libgpg-error/description
        An helper library for common error codes and descriptions.
-       This is a library that defines common error values for all GnuPG 
-       components. Among these are GPG, GPGSM, GPGME, GPG-Agent, libgcrypt, 
-       Libksba, DirMngr, Pinentry, SmartCard Daemon and possibly more in the 
+       This is a library that defines common error values for all GnuPG
+       components. Among these are GPG, GPGSM, GPGME, GPG-Agent, libgcrypt,
+       Libksba, DirMngr, Pinentry, SmartCard Daemon and possibly more in the
        future.
 endef
 
 TARGET_CFLAGS += $(FPIC)
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --disable-rpath \
-       )
-endef
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --disable-rpath
 
 define Build/InstallDev
        $(INSTALL_DIR) $(2)/bin $(1)/usr/bin