[packages] prosody: update to v0.4.0
authorNicolas Thill <nico@openwrt.org>
Mon, 27 Apr 2009 22:22:21 +0000 (22:22 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 27 Apr 2009 22:22:21 +0000 (22:22 +0000)
SVN-Revision: 15458

net/prosody/Makefile
net/prosody/patches/001-util_src_makefile.patch [deleted file]

index 6d25bfc301b020e3d55a8eb57e9efb0a9c419493..38dac00951aec89bbacb642dabcc84f7bb22d056 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=prosody
-PKG_VERSION:=0.3.0
+PKG_VERSION:=0.4.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://prosody.im/downloads/source/
-PKG_MD5SUM:=97b19d75b3d6770fb9b46b6452f945dd
+PKG_MD5SUM:=c143532a289a72d5d48b81b5bdac7c25
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -36,10 +36,11 @@ define Package/prosody/conffiles
 endef
 
 define Build/Configure
+       # this is *NOT* GNU autoconf stuff
        (cd $(PKG_BUILD_DIR); ./configure \
                --prefix=/usr \
                --with-lua="$(STAGING_DIR)/host/bin" \
-               --with-lua-include="$(STAGING_DIR)/usr/include/" \
+               --with-lua-include="$(STAGING_DIR)/usr/include" \
                --with-lua-lib="$(STAGING_DIR)/usr/lib" \
                --cflags="$(TARGET_CFLAGS)" \
        )
@@ -56,7 +57,7 @@ define Build/Compile
 endef
 
 define Package/prosody/install
-       $(INSTALL_DIR) $(1)/
+       $(INSTALL_DIR) $(1)
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/
 endef
 
diff --git a/net/prosody/patches/001-util_src_makefile.patch b/net/prosody/patches/001-util_src_makefile.patch
deleted file mode 100644 (file)
index f675d6f..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-diff -urN prosody-0.3.0/util-src/Makefile prosody-0.3.0.new/util-src/Makefile
---- prosody-0.3.0/util-src/Makefile    2009-02-02 19:05:21.000000000 +0100
-+++ prosody-0.3.0.new/util-src/Makefile        2009-02-15 14:44:53.000000000 +0100
-@@ -6,7 +6,7 @@
- LUA_LIB?=lua$(LUA_SUFFIX)
- IDN_LIB?=idn
- OPENSSL_LIB?=crypto
--
-+CC=gcc
- all: encodings.so hashes.so pposix.so
-@@ -21,18 +21,18 @@
-       rm -f ../util/*.so
- encodings.o: encodings.c
--      gcc $(CFLAGS) -I$(LUA_INCDIR) -c -o encodings.o encodings.c
-+      $(CC) $(CFLAGS) -I$(LUA_INCDIR) -c -o encodings.o encodings.c
- encodings.so: encodings.o
--      export MACOSX_DEPLOYMENT_TARGET="10.3"; gcc $(LFLAGS) -o encodings.so encodings.o -L/usr/local/lib -llua$(LUA_SUFFIX) -lidn
-+      export MACOSX_DEPLOYMENT_TARGET="10.3"; $(CC) $(LFLAGS) -o encodings.so encodings.o -L$(LUA_LIBDIR) -llua$(LUA_SUFFIX) -lidn
-       
- hashes.o: hashes.c
--      gcc $(CFLAGS) -I$(LUA_INCDIR) -c -o hashes.o hashes.c
-+      $(CC) $(CFLAGS) -I$(LUA_INCDIR) -c -o hashes.o hashes.c
- hashes.so: hashes.o
--      export MACOSX_DEPLOYMENT_TARGET="10.3"; gcc $(LFLAGS) -o hashes.so hashes.o -L/usr/local/lib -llua$(LUA_SUFFIX) -lcrypto
-+      export MACOSX_DEPLOYMENT_TARGET="10.3"; $(CC) $(LFLAGS) -o hashes.so hashes.o -L$(LUA_LIBDIR) -llua$(LUA_SUFFIX) -lcrypto
- pposix.o: pposix.c
--      gcc $(CFLAGS) -I$(LUA_INCDIR) -c -o pposix.o pposix.c
-+      $(CC) $(CFLAGS) -I$(LUA_INCDIR) -c -o pposix.o pposix.c
- pposix.so: pposix.o
--      export MACOSX_DEPLOYMENT_TARGET="10.3"; gcc $(LFLAGS) -o pposix.so pposix.o -L/usr/local/lib -llua$(LUA_SUFFIX)
-+      export MACOSX_DEPLOYMENT_TARGET="10.3"; $(CC) $(LFLAGS) -o pposix.so pposix.o -L$(LUA_LIBDIR) -llua$(LUA_SUFFIX)
-