add a patch to prevent the wrapper from linking when generating dep files
authorNicolas Thill <nico@openwrt.org>
Sun, 23 Sep 2007 12:28:31 +0000 (12:28 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 23 Sep 2007 12:28:31 +0000 (12:28 +0000)
SVN-Revision: 8976

libs/uclibc++/patches/005-wrapper.patch [new file with mode: 0644]

diff --git a/libs/uclibc++/patches/005-wrapper.patch b/libs/uclibc++/patches/005-wrapper.patch
new file mode 100644 (file)
index 0000000..b526a90
--- /dev/null
@@ -0,0 +1,12 @@
+diff -ruN uClibc++-0.2.2-old/bin/Makefile uClibc++-0.2.2-new/bin/Makefile
+--- uClibc++-0.2.2-old/bin/Makefile    2007-09-23 13:46:10.000000000 +0200
++++ uClibc++-0.2.2-new/bin/Makefile    2007-09-23 13:47:03.000000000 +0200
+@@ -25,7 +25,7 @@
+       echo 'while [ -n "$$1" ]' >> $(WRAPPER)
+       echo 'do' >> $(WRAPPER)
+       echo '  WRAPPER_OPTIONS="$$WRAPPER_OPTIONS $$1"' >> $(WRAPPER)
+-      echo '  if [ "$$1" = "-c" -o "$$1" = "-E" -o "$$1" = "-S" ]' >> $(WRAPPER)
++      echo '  if [ "$$1" = "-c" -o "$$1" = "-E" -o "$$1" = "-S" -o "$$1" = "-MF" ]' >> $(WRAPPER)
+       echo '  then' >> $(WRAPPER)
+       echo '          WRAPPER_INCLIB="N"' >> $(WRAPPER)
+       echo '  fi' >> $(WRAPPER)