Add libpciaccess.
authorLars-Peter Clausen <lars@metafoo.de>
Mon, 17 Nov 2008 22:43:31 +0000 (22:43 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Mon, 17 Nov 2008 22:43:31 +0000 (22:43 +0000)
SVN-Revision: 13271

Xorg/lib/libpciaccess/Makefile [new file with mode: 0644]

diff --git a/Xorg/lib/libpciaccess/Makefile b/Xorg/lib/libpciaccess/Makefile
new file mode 100644 (file)
index 0000000..b3484ee
--- /dev/null
@@ -0,0 +1,66 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_BASE_NAME:=libpciaccess
+PKG_NAME:=libpciaccess
+PKG_RELEASE:=1
+PKG_VERSION:=0.10.3
+PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.4/src/lib/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/${PKG_NAME}-$(PKG_VERSION)/
+PKG_FIXUP:=libtool
+
+include $(INCLUDE_DIR)/package.mk
+
+PKG_INSTALL:=1
+
+define Package/libpciaccess
+  SECTION:=xorg-libraries
+  CATEGORY:=Xorg
+  SUBMENU:=libraries
+  DEPENDS:=+pciutils
+  TITLE:=libpciaccess
+  URL:=http://xorg.freedesktop.org/
+endef
+
+define Build/Configure
+       $(call Build/Configure/Default, \
+               --with-pciids-path=/usr/share/pci.ids \
+               , \
+               ac_cv_file__usr_include_asm_mtrr_h=$(shell \
+               test -f "$(TOOLCHAIN_DIR)/include/asm/mtrr.h" \
+                       && echo "yes" \
+                       || echo "no") \
+       )
+endef
+
+define Package/libpciaccess/install
+       $(INSTALL_DIR) $(1)/usr/include
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/include/*.h \
+               $(1)/usr/include
+
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/libpciaccess.so* \
+               $(1)/usr/lib/
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/libpciaccess.{so*,a,la} \
+               $(1)/usr/lib/
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* \
+               $(1)/usr/lib/pkgconfig/
+endef
+
+$(eval $(call BuildPackage,libpciaccess))