[package] kernel/modules: package the VSC7385 driver
authorGabor Juhos <juhosg@openwrt.org>
Thu, 4 Jun 2009 07:54:10 +0000 (07:54 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 4 Jun 2009 07:54:10 +0000 (07:54 +0000)
SVN-Revision: 16325

package/kernel/modules/spi.mk

index 7e74239ed9e8d198ca9d6bac2b78dc4229942f61..48e105f2c21d68d31c0af5a43a06080b6e0b669d 100644 (file)
@@ -104,3 +104,19 @@ define KernelPackage/bcm63xx-spi/description
 endef
 
 $(eval $(call KernelPackage,bcm63xx-spi))
 endef
 
 $(eval $(call KernelPackage,bcm63xx-spi))
+
+
+define KernelPackage/spi-vsc7385
+  SUBMENU:=$(SPI_MENU)
+  TITLE:=Vitesse VSC7385 ethernet switch driver
+  DEPENDS:=@TARGET_ar71xx
+  KCONFIG:=CONFIG_SPI_VSC7385
+  FILES:=$(LINUX_DIR)/drivers/spi/spi_vsc7385.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,93,spi_vsc7385)
+endef
+
+define KernelPackage/spi-vsc7385/description
+  This package contains the SPI driver for the Vitesse VSC7385 ethernet switch.
+endef
+
+$(eval $(call KernelPackage,spi-vsc7385))