package/kernel: various NLS handling fixes
authorNicolas Thill <nico@openwrt.org>
Sat, 29 Oct 2011 15:03:56 +0000 (15:03 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 29 Oct 2011 15:03:56 +0000 (15:03 +0000)
 * move AddDepends/nls to 001-depends.mk for proper use by other packages (closes: #7639)
 * make kmod-usb-core use it
 * fix deps generated from its arguments (as used in kmod-fs-hfsplus)

SVN-Revision: 28668

package/kernel/modules/001-depends.mk
package/kernel/modules/fs.mk
package/kernel/modules/nls.mk
package/kernel/modules/usb.mk

index 73dd46b9106663cfe9014850d3ce917f9491e84f..407f873a5e02255cba65489e3fcc9be9ab2a0a1a 100644 (file)
@@ -18,6 +18,11 @@ define AddDepends/input
 endef
 
 
+define AddDepends/nls
+  DEPENDS+= +kmod-nls-base $(foreach cp,$(1),+kmod-nls-$(cp))
+endef
+
+
 define SetDepends/rfkill
   DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_gemini)
 endef
index c1727c0a1b44b4a52b39d267f2adc5e449021959..913042ae9702ac405801936c529c9df469c8ca2c 100644 (file)
@@ -47,7 +47,7 @@ define KernelPackage/fs-cifs
   KCONFIG:=CONFIG_CIFS
   FILES:=$(LINUX_DIR)/fs/cifs/cifs.ko
   AUTOLOAD:=$(call AutoLoad,30,cifs)
-$(call AddDepends/nls)
+  $(call AddDepends/nls)
   DEPENDS+= \
     +!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36):kmod-crypto-arc4 \
     +!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36):kmod-crypto-hmac \
@@ -147,7 +147,7 @@ define KernelPackage/fs-hfs
   KCONFIG:=CONFIG_HFS_FS
   FILES:=$(LINUX_DIR)/fs/hfs/hfs.ko
   AUTOLOAD:=$(call AutoLoad,30,hfs)
-$(call AddDepends/nls)
+  $(call AddDepends/nls)
 endef
 
 define KernelPackage/fs-hfs/description
@@ -163,7 +163,7 @@ define KernelPackage/fs-hfsplus
   KCONFIG:=CONFIG_HFSPLUS_FS
   FILES:=$(LINUX_DIR)/fs/hfsplus/hfsplus.ko
   AUTOLOAD:=$(call AutoLoad,30,hfsplus)
-$(call AddDepends/nls,utf8)
+  $(call AddDepends/nls,utf8)
 endef
 
 define KernelPackage/fs-hfsplus/description
@@ -179,7 +179,7 @@ define KernelPackage/fs-isofs
   KCONFIG:=CONFIG_ISO9660_FS CONFIG_JOLIET=y CONFIG_ZISOFS=n
   FILES:=$(LINUX_DIR)/fs/isofs/isofs.ko
   AUTOLOAD:=$(call AutoLoad,30,isofs)
-$(call AddDepends/nls)
+  $(call AddDepends/nls)
 endef
 
 define KernelPackage/fs-isofs/description
@@ -210,7 +210,7 @@ define KernelPackage/fs-msdos
   KCONFIG:=CONFIG_MSDOS_FS
   FILES:=$(LINUX_DIR)/fs/fat/msdos.ko
   AUTOLOAD:=$(call AutoLoad,40,msdos)
-$(call AddDepends/nls)
+  $(call AddDepends/nls)
 endef
 
 define KernelPackage/fs-msdos/description
@@ -294,7 +294,7 @@ define KernelPackage/fs-ntfs
   KCONFIG:=CONFIG_NTFS_FS
   FILES:=$(LINUX_DIR)/fs/ntfs/ntfs.ko
   AUTOLOAD:=$(call AutoLoad,30,ntfs)
-$(call AddDepends/nls)
+  $(call AddDepends/nls)
 endef
 
 define KernelPackage/fs-ntfs/description
@@ -326,7 +326,7 @@ define KernelPackage/fs-udf
   FILES:=$(LINUX_DIR)/fs/udf/udf.ko
   AUTOLOAD:=$(call AutoLoad,30,udf)
   DEPENDS:=+kmod-lib-crc-itu-t
-$(call AddDepends/nls)
+  $(call AddDepends/nls)
 endef
 
 define KernelPackage/fs-udf/description
@@ -346,7 +346,7 @@ define KernelPackage/fs-vfat
        $(LINUX_DIR)/fs/fat/fat.ko \
        $(LINUX_DIR)/fs/fat/vfat.ko
   AUTOLOAD:=$(call AutoLoad,30,fat vfat)
-$(call AddDepends/nls)
+  $(call AddDepends/nls)
 endef
 
 define KernelPackage/fs-vfat/description
index 5b9565dac9e62f9ecb10191c991799b00c1c0ecf..28791b6b7b220b4976db926f8726a5273f895dc5 100644 (file)
@@ -1,14 +1,10 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
-define AddDepends/nls
-  DEPENDS+= +kmod-nls-base
-endef
-
 define KernelPackage/nls-base
   SUBMENU:=Native Language Support
   TITLE:=Native Language Support
index b72a34628611b7b9ab43e1b6b34b2aab61688aeb..d5b58ffb35fe15970235b5fb8238fd6204bd5f0e 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -14,10 +14,11 @@ USBINPUT_DIR?=input/misc
 define KernelPackage/usb-core
   SUBMENU:=$(USB_MENU)
   TITLE:=Support for USB
-  DEPENDS:=@USB_SUPPORT +kmod-nls-base
+  DEPENDS:=@USB_SUPPORT
   KCONFIG:=CONFIG_USB CONFIG_XPS_USB_HCD_XILINX=n CONFIG_USB_FHCI_HCD=n
   FILES:=$(LINUX_DIR)/drivers/usb/core/usbcore.ko
   AUTOLOAD:=$(call AutoLoad,20,usbcore,1)
+  $(call AddDepends/nls)
 endef
 
 define KernelPackage/usb-core/description