[packages] git: prevent spurious rebuilds caused by $(MAKE) ... install being called...
authorNicolas Thill <nico@openwrt.org>
Tue, 6 Apr 2010 09:14:51 +0000 (09:14 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 6 Apr 2010 09:14:51 +0000 (09:14 +0000)
SVN-Revision: 20730

net/git/Makefile

index a02e7ff8b2e29812b39a45bf2ca5db40649987c2..5a220fa2a8adadbb4b2915cf041aebade8ee1af9 100644 (file)
@@ -16,6 +16,8 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@KERNEL/software/scm/git
 PKG_MD5SUM:=03aefaaecae7a236b88d04d1a83698d9
 
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/git
@@ -33,6 +35,20 @@ define Package/git/description
  with speed and efficiency.
 endef
 
+MAKE_FLAGS := \
+       CC="$(TARGET_CC)" \
+       LD="$(TARGET_CC)" \
+       CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+       CPPFLAGS="$(TARGET_CPPFLAGS)" \
+       LDFLAGS="$(TARGET_LDFLAGS)" \
+       NO_PERL="YesPlease" \
+       NO_EXPAT="YesPlease" \
+       NO_WISH="YesPlease" \
+       NO_ICONV="YesPlease" \
+       NO_NSEC="YesPlease" \
+       NO_CURL="YesPlease" \
+       NO_TCLTK="YesPlease" \
+
 define Build/Configure
        $(MAKE) -C $(PKG_BUILD_DIR) \
                configure
@@ -43,39 +59,9 @@ define Build/Configure
        );
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" \
-               LD="$(TARGET_CC)" \
-               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
-               CPPFLAGS="$(TARGET_CPPFLAGS)" \
-               LDFLAGS="$(TARGET_LDFLAGS)" \
-               NO_PERL="YesPlease" \
-               NO_EXPAT="YesPlease" \
-               NO_WISH="YesPlease" \
-               NO_ICONV="YesPlease" \
-               NO_NSEC="YesPlease" \
-               NO_CURL="YesPlease" \
-               NO_TCLTK="YesPlease" \
-               all
-endef
-
 define Package/git/install
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(1)" \
-               CC="$(TARGET_CC)" \
-               LD="$(TARGET_CC)" \
-               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
-               CPPFLAGS="$(TARGET_CPPFLAGS)" \
-               LDFLAGS="$(TARGET_LDFLAGS)" \
-               NO_PERL="YesPlease" \
-               NO_EXPAT="YesPlease" \
-               NO_WISH="YesPlease" \
-               NO_ICONV="YesPlease" \
-               NO_NSEC="YesPlease" \
-               NO_CURL="YesPlease" \
-               NO_TCLTK="YesPlease" \
-               install
+       $(INSTALL_DIR) $(1)
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
 endef
 
 $(eval $(call BuildPackage,git))