add support for pppoe over atheros wlan
authorFelix Fietkau <nbd@openwrt.org>
Sat, 20 Aug 2005 14:30:28 +0000 (14:30 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 20 Aug 2005 14:30:28 +0000 (14:30 +0000)
SVN-Revision: 1702

openwrt/package/ppp/Makefile
openwrt/package/ppp/patches/205-pppoe_iface_name.patch

index f248412ae9d4065e2c7491789f383252de2612da..0fed25c91e98b9045e88ab2847f171b290475f01 100644 (file)
@@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ppp
 PKG_VERSION:=2.4.3
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 PKG_MD5SUM:=848f6c3cafeb6074ffeb293c3af79b7c
 
 PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
index 522d5878a4305d534bc5bd69229f8c554edb0858..0961eca623143632e84339f4348120fdcbb511a7 100644 (file)
@@ -6,7 +6,7 @@ diff -ruN ppp-2.4.3-orig/pppd/plugins/rp-pppoe/plugin.c ppp-2.4.3-3/pppd/plugins
        cmd += 4;
      } else if (strlen(cmd) < 4
 -             || (strncmp(cmd, "eth", 3) && strncmp(cmd, "nas", 3)
-+             || (strncmp(cmd, "eth", 3) && strncmp(cmd, "nas", 3) && strncmp(cmd, "vlan", 4)
++             || (strncmp(cmd, "eth", 3) && strncmp(cmd, "nas", 3) && strncmp(cmd, "vlan", 4) && strncmp(cmd, "ath", 3)
                   && strncmp(cmd, "tap", 3) && strncmp(cmd, "br", 2))) {
        return 0;
      }