The 6tunnel and 6bridge helpers should be packaged separately from 6tunnel which...
authorFlorian Fainelli <florian@openwrt.org>
Fri, 18 Jul 2008 14:04:18 +0000 (14:04 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 18 Jul 2008 14:04:18 +0000 (14:04 +0000)
SVN-Revision: 11858

ipv6/6tunnel/Makefile
ipv6/6tunnel/files/6bridge.conf [deleted file]
ipv6/6tunnel/files/6bridge.init [deleted file]
ipv6/6tunnel/files/6tunnel.conf [deleted file]
ipv6/6tunnel/files/6tunnel.init [deleted file]

index 64afbff24def9002d8309def4ba477dca7ae8193..189238d1435cbf0d3fa916a3ca11b78b6403d9d1 100644 (file)
@@ -44,19 +44,9 @@ define Build/Compile
                default
 endef
 
-define Package/6tunnel/conffiles
-/etc/config/6tunnel
-endef
-
 define Package/6tunnel/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/6tunnel $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DATA) ./files/6tunnel.conf $(1)/etc/config/6tunnel
-       $(INSTALL_DATA) ./files/6bridge.conf $(1)/etc/config/6bridge
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/6tunnel.init $(1)/etc/init.d/6tunnel
-       $(INSTALL_BIN) ./files/6bridge.init $(1)/etc/init.d/6bridge
 endef
 
 $(eval $(call BuildPackage,6tunnel))
diff --git a/ipv6/6tunnel/files/6bridge.conf b/ipv6/6tunnel/files/6bridge.conf
deleted file mode 100644 (file)
index e2980ad..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-config 6bridge
-       option bridge   'bripv6'        
diff --git a/ipv6/6tunnel/files/6bridge.init b/ipv6/6tunnel/files/6bridge.init
deleted file mode 100644 (file)
index ba98d66..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-#!/bin/sh /etc/rc.common
-START=46
-STOP=46
-
-start_service() {
-       local section="$1"
-       
-       include /lib/network
-       scan_interfaces
-       config_load /var/state/network
-
-       config_get LAN lan ifname
-       config_get WAN wan ifname
-       config_get bridge "$section" bridge
-
-       brctl addbr $bridge
-       brctl addif $bridge $LAN
-       brctl addif $bridge $WAN
-       brctl setfd $bridge 0
-        ebtables -t broute -A BROUTING -i $WAN -p ! ipv6 -j DROP
-        ifconfig $bridge up
-}
-
-stop_service() {
-        local section="$1"
-
-        include /lib/network
-        scan_interfaces
-        config_load /var/state/network
-
-        config_get LAN lan ifname
-        config_get WAN wan ifname
-        config_get bridge "$section" bridge
-
-        ifconfig $bridge down
-        ebtables -t broute -F
-        brctl delif $bridge $WAN
-        brctl delif $bridge $LAN
-        brctl delbr $bridge
-}
-start() {
-        if ! [ -f /proc/net/if_inet6 ]; then
-                echo "IPv6 not enabled, install kmod-ipv6";
-                exit 1;
-        fi
-        config_load "6bridge"
-        config_foreach start_service 6bridge
-}
-
-stop () {
-        config_load "6bridge"
-        config_foreach stop_service 6bridge
-}
diff --git a/ipv6/6tunnel/files/6tunnel.conf b/ipv6/6tunnel/files/6tunnel.conf
deleted file mode 100644 (file)
index efd8f81..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-config 6tunnel
-        option tnlifname     'sixbone'
-        option remoteip4       ''
-       option localip4         ''
-       option localip6         ''
-       option prefix           '/64'
diff --git a/ipv6/6tunnel/files/6tunnel.init b/ipv6/6tunnel/files/6tunnel.init
deleted file mode 100644 (file)
index cd4e1fc..0000000
+++ /dev/null
@@ -1,64 +0,0 @@
-#!/bin/sh /etc/rc.common
-START=46
-STOP=46
-
-start_service() {
-       local section="$1"
-       
-       include /lib/network
-       scan_interfaces
-       config_load /var/state/network
-
-       config_get LAN lan ifname
-        config_get tnlifname "$section" tnlifname
-       config_get remoteip4 "$section" remoteip4
-       config_get localip4 "$section" localip4
-       config_get localip6 "$section" localip6
-       config_get prefix "$section" prefix
-
-       ip tunnel add $tnlifname mode sit remote $remoteip4 local $localip4 ttl 255
-       ifconfig $tnlifname up
-       ip addr add $localip6 dev $tnlifname
-       ip route add ::/0 dev $tnlifname
-       ip route add 2000::/3 dev $tnlifname
-       ip -6 addr add $prefix dev $LAN
-}
-
-stop_service() {
-       local section="$1"
-       
-       include /lib/network
-       scan_interfaces
-       config_load /var/state/network
-
-       config_get LAN lan ifname
-        config_get tnlifname "$section" tnlifname
-       config_get remoteip4 "$section" remoteip4
-       config_get localip4 "$section" localip4
-       config_get localip6 "$section" localip6
-       config_get prefix "$section" prefix
-
-       ip -6 addr del $prefix dev $LAN
-       ip -6 ro del 2000::/3 dev $tnlifname
-       ip -6 ro del ::/0 dev $tnlifname
-       ip addr del $localip6 dev $tnlifname
-       ifconfig $tnlifname down
-       ip tunnel del $tnlifname
-}
-start() {
-       if ! [ -f /proc/net/if_inet6 ]; then
-               echo "IPv6 not enabled, install kmod-ipv6";
-               exit 1;
-       fi
-       if ! [ -x /sbin/ip ]; then
-               echo "ip is required to setup the tunnel";
-               exit 1;
-       fi
-       config_load "6tunnel"
-       config_foreach start_service 6tunnel
-}
-
-stop () {
-       config_load "6tunnel"
-       config_foreach stop_service 6tunnel
-}