ar71xx: add kernel support for TPLINK WR720N v3
authorGabor Juhos <juhosg@openwrt.org>
Fri, 26 Apr 2013 17:00:48 +0000 (17:00 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 26 Apr 2013 17:00:48 +0000 (17:00 +0000)
Add support for TPLINK WR720N v3 which has 4MB flash,
32MB ram, 2 ethernet interfaces, 1 USB 2.0 port.

The patch is mostly a modification from mach-tl-wr703n.c.
GPIO numbers for the slider switch is from mach-tl-mr3020n.c.

Tested on my device and they worked fine.

Signed-off-by: yousong <yszhou4tech@gmail.com>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 36456

target/linux/ar71xx/config-3.8
target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wr720n-v3.c [new file with mode: 0644]
target/linux/ar71xx/patches-3.8/617-MIPS-ath79-TL-WR720N-v3-support.patch [new file with mode: 0644]

index 847b9a50342f848f1a9dc961fba183d1c237c75d..f76f57927aad460c3d0629e162b3e635661156e1 100644 (file)
@@ -72,6 +72,7 @@ CONFIG_ATH79_MACH_TL_WR1041N_V2=y
 CONFIG_ATH79_MACH_TL_WR1043ND=y
 CONFIG_ATH79_MACH_TL_WR2543N=y
 CONFIG_ATH79_MACH_TL_WR703N=y
 CONFIG_ATH79_MACH_TL_WR1043ND=y
 CONFIG_ATH79_MACH_TL_WR2543N=y
 CONFIG_ATH79_MACH_TL_WR703N=y
+CONFIG_ATH79_MACH_TL_WR720N_V3=y
 CONFIG_ATH79_MACH_TL_WR741ND=y
 CONFIG_ATH79_MACH_TL_WR741ND_V4=y
 CONFIG_ATH79_MACH_TL_WR841N_V1=y
 CONFIG_ATH79_MACH_TL_WR741ND=y
 CONFIG_ATH79_MACH_TL_WR741ND_V4=y
 CONFIG_ATH79_MACH_TL_WR841N_V1=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wr720n-v3.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wr720n-v3.c
new file mode 100644 (file)
index 0000000..80e8df6
--- /dev/null
@@ -0,0 +1,109 @@
+/*
+ *  TP-LINK TL-WR720N board support
+ *
+ *  Copyright (C) 2011 dongyuqi <729650915@qq.com>
+ *  Copyright (C) 2011-2012 Gabor Juhos <juhosg@openwrt.org>
+ *  Copyright (C) 2013 yousong <yszhou4tech@gmail.com>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+
+#include <asm/mach-ath79/ath79.h>
+
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define TL_WR720N_GPIO_LED_SYSTEM      27
+#define TL_WR720N_GPIO_BTN_RESET       11
+#define TL_WR720N_GPIO_BTN_SW1         18
+#define TL_WR720N_GPIO_BTN_SW2         20
+
+#define TL_WR720N_GPIO_USB_POWER       8
+
+#define TL_WR720N_KEYS_POLL_INTERVAL   20      /* msecs */
+#define TL_WR720N_KEYS_DEBOUNCE_INTERVAL       (3 * TL_WR720N_KEYS_POLL_INTERVAL)
+
+static const char *tl_wr720n_part_probes[] = {
+       "tp-link",
+       NULL,
+};
+
+static struct flash_platform_data tl_wr720n_flash_data = {
+       .part_probes    = tl_wr720n_part_probes,
+};
+
+static struct gpio_led tl_wr720n_leds_gpio[] __initdata = {
+       {
+               .name           = "tp-link:blue:system",
+               .gpio           = TL_WR720N_GPIO_LED_SYSTEM,
+               .active_low     = 1,
+       },
+};
+
+static struct gpio_keys_button tl_wr720n_gpio_keys[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = TL_WR720N_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = TL_WR720N_GPIO_BTN_RESET,
+               .active_low     = 0,
+       }, {
+               .desc           = "sw1",
+               .type           = EV_KEY,
+               .code           = BTN_0,
+               .debounce_interval = TL_WR720N_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = TL_WR720N_GPIO_BTN_SW1,
+               .active_low = 0,
+       }, {
+               .desc           = "sw2",
+               .type           = EV_KEY,
+               .code           = BTN_1,
+               .debounce_interval = TL_WR720N_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = TL_WR720N_GPIO_BTN_SW2,
+               .active_low = 0,
+       }
+};
+
+static void __init tl_wr720n_v3_setup(void)
+{
+       u8 *mac = (u8 *) KSEG1ADDR(0x1f01fc00);
+       u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
+
+       /* disable PHY_SWAP and PHY_ADDR_SWAP bits */
+       ath79_setup_ar933x_phy4_switch(false, false);
+
+       ath79_register_m25p80(&tl_wr720n_flash_data);
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(tl_wr720n_leds_gpio),
+                                       tl_wr720n_leds_gpio);
+       ath79_register_gpio_keys_polled(-1, TL_WR720N_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(tl_wr720n_gpio_keys),
+                                       tl_wr720n_gpio_keys);
+
+       gpio_request_one(TL_WR720N_GPIO_USB_POWER,
+                       GPIOF_OUT_INIT_HIGH | GPIOF_EXPORT_DIR_FIXED,
+                       "USB power");
+       ath79_register_usb();
+
+       ath79_init_mac(ath79_eth0_data.mac_addr, mac, 1);
+       ath79_init_mac(ath79_eth1_data.mac_addr, mac, 2);
+
+       ath79_register_mdio(0, 0x0);
+       ath79_register_eth(0);
+       ath79_register_eth(1);
+
+       ath79_register_wmac(ee, mac);
+}
+
+MIPS_MACHINE(ATH79_MACH_TL_WR720N_V3, "TL-WR720N-v3", "TP-LINK TL-WR720N v3",
+               tl_wr720n_v3_setup);
+
diff --git a/target/linux/ar71xx/patches-3.8/617-MIPS-ath79-TL-WR720N-v3-support.patch b/target/linux/ar71xx/patches-3.8/617-MIPS-ath79-TL-WR720N-v3-support.patch
new file mode 100644 (file)
index 0000000..e4a338f
--- /dev/null
@@ -0,0 +1,39 @@
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -94,6 +94,7 @@ enum ath79_mach_type {
+       ATH79_MACH_TL_WR1043ND,         /* TP-LINK TL-WR1043ND */
+       ATH79_MACH_TL_WR2543N,          /* TP-LINK TL-WR2543N/ND */
+       ATH79_MACH_TL_WR703N,           /* TP-LINK TL-WR703N */
++      ATH79_MACH_TL_WR720N_V3,        /* TP-LINK TL-WR720N v3 */
+       ATH79_MACH_TL_WR741ND,          /* TP-LINK TL-WR741ND */
+       ATH79_MACH_TL_WR741ND_V4,       /* TP-LINK TL-WR741ND  v4*/
+       ATH79_MACH_TL_WR841N_V1,        /* TP-LINK TL-WR841N v1 */
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -556,6 +556,16 @@ config ATH79_MACH_TL_WR703N
+       select ATH79_DEV_USB
+       select ATH79_DEV_WMAC
++config ATH79_MACH_TL_WR720N_V3
++      bool "TP-LINK TL-WR720N v3 support"
++      select SOC_AR933X
++      select ATH79_DEV_ETH
++      select ATH79_DEV_GPIO_BUTTONS
++      select ATH79_DEV_LEDS_GPIO
++      select ATH79_DEV_M25P80
++      select ATH79_DEV_USB
++      select ATH79_DEV_WMAC
++
+ config ATH79_MACH_TL_WR741ND
+       bool "TP-LINK TL-WR741ND support"
+       select SOC_AR724X
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -93,6 +93,7 @@ obj-$(CONFIG_ATH79_MACH_TL_WR1041N_V2)       +
+ obj-$(CONFIG_ATH79_MACH_TL_WR1043ND)  += mach-tl-wr1043nd.o
+ obj-$(CONFIG_ATH79_MACH_TL_WR2543N)   += mach-tl-wr2543n.o
+ obj-$(CONFIG_ATH79_MACH_TL_WR703N)    += mach-tl-wr703n.o
++obj-$(CONFIG_ATH79_MACH_TL_WR720N_V3) += mach-tl-wr720n-v3.o
+ obj-$(CONFIG_ATH79_MACH_UBNT)         += mach-ubnt.o
+ obj-$(CONFIG_ATH79_MACH_UBNT_XM)      += mach-ubnt-xm.o
+ obj-$(CONFIG_ATH79_MACH_WHR_HP_G300N) += mach-whr-hp-g300n.o