packages/nrpe: use new service functions, move user/group creation from postinst...
authorNicolas Thill <nico@openwrt.org>
Wed, 9 Nov 2011 19:48:57 +0000 (19:48 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 9 Nov 2011 19:48:57 +0000 (19:48 +0000)
SVN-Revision: 28888

admin/nrpe/Makefile
admin/nrpe/files/nrpe.init

index 3835b144366b125f50f8a6726e88440e22adcbd5..02be6bf2b1975487c826b0d0da68e7712251f564 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nrpe
 PKG_VERSION:=2.12
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/nagios
@@ -34,42 +34,6 @@ define Package/nrpe/description
        the remote Linux/Unix machines.
 endef
 
-define Package/nrpe/postinst
-#!/bin/sh
-
-id=50
-name=nagios
-home=/var/run/nagios
-shell=/bin/false
-
-# do not change below
-# check if we are on real system
-if [ -z "$${IPKG_INSTROOT}" ]; then
-        # create copies of passwd and group, if we use squashfs
-        rootfs=`mount |awk '/root/ { print $$5 }'`
-        if [ "$$rootfs" = "squashfs" ]; then
-                if [ -h /etc/group ]; then
-                        rm /etc/group
-                        cp -p /rom/etc/group /etc/group
-                fi
-                if [ -h /etc/passwd ]; then
-                        rm /etc/passwd
-                        cp -p /rom/etc/passwd /etc/passwd
-                fi
-        fi
-fi
-
-echo ""
-if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then
-        echo "adding group $$name to /etc/group"
-        echo "$${name}:x:$${id}:" >> $${IPKG_INSTROOT}/etc/group
-fi
-if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
-        echo "adding user $$name to /etc/passwd"
-        echo "$${name}:x:$${id}:$${id}:$${name}:$${home}:$${shell}" >> $${IPKG_INSTROOT}/etc/passwd
-fi
-endef
-
 CONFIGURE_ARGS += \
        --with-ssl="$(STAGING_DIR)/usr" \
        --with-ssl-lib="$(STAGING_DIR)/usr/lib"
index e1ccf8ad96126405caa315a739c9afb798a440bb..4632ac1fa1aacc621b868af67f244600fc17a9bb 100644 (file)
@@ -1,12 +1,20 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 
 START=70
 
+SERVICE_USE_PID=1
+
 start() {
-       /usr/sbin/nrpe -c /etc/nrpe.cfg -d
+       user_exists nagios 50 || user_add nagios 50
+       group_exists nagios 50 || group_add nagios 50
+       [ -d /var/run/nagios ] || {
+               mkdir -m 0755 -p /var/run/nagios
+               chown nagios:nagios /var/run/nagios
+       }
+       service_start /usr/sbin/nrpe -c /etc/nrpe.cfg -d
 }
 
 stop() {
-        killall nrpe
+       service_stop /usr/sbin/nrpe
 }