port kmod-ipv6 to the new system
authorFelix Fietkau <nbd@openwrt.org>
Sun, 20 Aug 2006 17:27:24 +0000 (17:27 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 20 Aug 2006 17:27:24 +0000 (17:27 +0000)
SVN-Revision: 4615

openwrt/include/modules-2.4.mk
openwrt/include/modules-2.6.mk
openwrt/package/kernel/modules.mk
openwrt/target/linux/Config.in

index b00b61c83aadb8eab0cde28ccb3b9796aaa6e6ea..7ef332363990eaa8baf0d4bcc904171747b9f766 100644 (file)
@@ -21,10 +21,6 @@ $(eval $(call KMOD_template,IPIP,ipip,\
        $(MODULES_DIR)/kernel/net/ipv4/ipip.o \
 ,CONFIG_NET_IPIP,,60,ipip))
 
-$(eval $(call KMOD_template,IPV6,ipv6,\
-       $(MODULES_DIR)/kernel/net/ipv6/ipv6.o \
-,CONFIG_IPV6,,20,ipv6))
-
 $(eval $(call KMOD_template,SCHED,sched,\
        $(MODULES_DIR)/kernel/net/sched/*.o \
 ))
index a0ff900aa6a08e9c12d21281f8d6567f112feaba..4ea28fb1679e10aab739035c7dc7c7f1826f4567 100644 (file)
@@ -23,10 +23,6 @@ $(eval $(call KMOD_template,IPIP,ipip,\
        $(MODULES_DIR)/kernel/net/ipv4/ipip.ko \
 ,CONFIG_NET_IPIP,,60,ipip))
 
-$(eval $(call KMOD_template,IPV6,ipv6,\
-       $(MODULES_DIR)/kernel/net/ipv6/ipv6.ko \
-,CONFIG_IPV6,,20,ipv6))
-
 $(eval $(call KMOD_template,SCHED,sched,\
        $(MODULES_DIR)/kernel/net/sched/*.ko \
 ,CONFIG_NET_SCHED))
index 51b7d8ace5d8610b04b2eeba4becfa221b7b69c9..090945c3e06311f016bafaa2245c0c44b36ab280 100644 (file)
@@ -281,6 +281,13 @@ KCONFIG:=$(CONFIG_BRIDGE_NF_EBTABLES)
 endef
 $(eval $(call KernelPackage,ebtables))
 
+define KernelPackage/ipv6
+TITLE:=IPv6 support
+DESCRIPTION:=Kernel modules for IPv6 support
+KCONFIG:=$(CONFIG_IPV6)
+FILES:=$(MODULES_DIR)/kernel/net/ipv6/ipv6.$(LINUX_KMOD_SUFFIX)
+endef
+$(eval $(call KernelPackage,ipv6))
 
 define KernelPackage/ppp
 TITLE:=PPP modules
index 7589ea7b697f3cc6c314e30f8a5f0e0e056901ae..f9c72c01a52e59de685cc6ff865b8e1f55d5085f 100644 (file)
@@ -30,13 +30,6 @@ config PACKAGE_KMOD_IPIP
        help
          Kernel module for IP in IP encapsulation
 
-config PACKAGE_KMOD_IPV6
-       prompt "kmod-ipv6......................... IPv6 support"
-       tristate
-       default m
-       help
-         Kernel modules for IPv6 protocol support
-
 config PACKAGE_KMOD_RING
        prompt "kmod-ring......................... PF Ring"
        tristate