packages: Fix multiple download urls.
authorAndy Boyett <agb@openwrt.org>
Wed, 13 Feb 2008 21:49:01 +0000 (21:49 +0000)
committerAndy Boyett <agb@openwrt.org>
Wed, 13 Feb 2008 21:49:01 +0000 (21:49 +0000)
SVN-Revision: 10456

admin/syslog-ng/Makefile
ipv6/ndisc/Makefile
lang/egenix-mx/Makefile
libs/rrdtool-1.0.x/Makefile
net/tor/Makefile

index 895d76118f2e40d8f59a656308a1406abad0d023..abd24e7614f4eaa8320c9eadd0dba8669592347e 100644 (file)
@@ -13,8 +13,8 @@ PKG_VERSION:=1.6.12
 PKG_RELEASE:=1
 PKG_MD5SUM:=a3cbfdb6e1e5beea181a7349749719f3
 
-PKG_SOURCE_URL:= http://www.balabit.com/downloads/syslog-ng/1.6/src \
-               http://www.balabit.com/downloads/syslog-ng/stable/src
+PKG_SOURCE_URL:= http://www.balabit.com/downloads/files/syslog-ng/sources/1.6/src \
+               http://www.balabit.com/downloads/files/syslog-ng/stable/src
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 
 include $(INCLUDE_DIR)/package.mk
index eef6dbcb80df5901664a2e21cc5f30c09d0c4f8f..56c0387253b1bbb5cc42c816a270ff46d9b2370f 100644 (file)
@@ -13,7 +13,8 @@ PKG_VERSION:=0.5.1
 PKG_RELEASE:=1
 PKG_MD5SUM:=33487fe5505b195eb31468d88ba9ab56
 
-PKG_SOURCE_URL:=http://people.via.ecp.fr/~rem/ndisc6/
+PKG_SOURCE_URL:=http://www.remlab.net/files/ndisc6/ \
+       http://www.remlab.net/files/ndisc6/archive/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -53,31 +54,31 @@ endef
 define Package/tcptraceroute6
   $(call Package/ndisc)
   TITLE:=A TCP/IPv6-based traceroute implementation
-endef 
+endef
 
 define Package/tcptraceroute6/description
 A TCP/IPv6-based traceroute implementation
 endef
-  
 
-define Build/Compile   
+
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
                all
 endef
 
-define Package/ndisc6/install  
+define Package/ndisc6/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ndisc6 $(1)/usr/bin/
 endef
 
-define Package/rdisc6/install  
+define Package/rdisc6/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/rdisc6 $(1)/usr/bin/
 endef
 
-define Package/tcptraceroute6/install  
+define Package/tcptraceroute6/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/tcptraceroute6 $(1)/usr/bin/
 endef
index e75f3c1c7b3103251eb77d1ee9dcc6fdc5398467..496de826e25d73387c3b0e398b4bee17cd77bffb 100644 (file)
@@ -13,7 +13,7 @@ PKG_VERSION:=2.0.6
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-base-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.egenix.com/files/python/
+PKG_SOURCE_URL:=http://downloads.egenix.com/python/
 PKG_MD5SUM:=66841151728a06f92d0b8dd2ed317a29
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-base-$(PKG_VERSION)
index b9403281fce98ee4d7678f327e575192361547e4..cb982fe46c654f6bfc5aef02a3058caa37ce134f 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -13,8 +13,11 @@ PKG_VERSION:=1.0.50
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/rrdtool-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/pub/rrdtool-1.0.x
+PKG_SOURCE:=rrdtool-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:= \
+       http://oss.oetiker.ch/rrdtool/pub/rrdtool-1.0.x \
+       http://www.fastmirrors.org/rrdtool/rrdtool-1.0.x \
+       ftp://ftp.sunet.se/pub/network/monitoring/rrdtool/rrdtool-1.0.x
 PKG_MD5SUM:=c466e2e7df95fa8e318e46437da87686
 
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -31,18 +34,18 @@ endef
 
 define Package/librrd1/description
 Round Robin Database (RRD) management library.
-       RRD is the Acronym for Round Robin Database. RRD is a system to store and 
-       display time-series data (i.e. network bandwidth, machine-room temperature, 
-       server load average). It stores the data in a very compact way that will 
-       not expand over time, and it presents useful graphs by processing the data 
-       to enforce a certain data density. It can be used either via simple wrapper 
-       scripts (from shell or Perl) or via frontends that poll network devices and 
+       RRD is the Acronym for Round Robin Database. RRD is a system to store and
+       display time-series data (i.e. network bandwidth, machine-room temperature,
+       server load average). It stores the data in a very compact way that will
+       not expand over time, and it presents useful graphs by processing the data
+       to enforce a certain data density. It can be used either via simple wrapper
+       scripts (from shell or Perl) or via frontends that poll network devices and
        put friendly user interface on it.
-       
-       This is version 1.0.x with cgilib-0.4, gd1.3 and libpng-1.0.9 linked into 
-       librrd.so. The library is much smaller compared to the 1.2.x version with 
+
+       This is version 1.0.x with cgilib-0.4, gd1.3 and libpng-1.0.9 linked into
+       librrd.so. The library is much smaller compared to the 1.2.x version with
        separate dynamic linked libraries.
-       
+
        This package contains a shared library, used by other programs.
 endef
 
@@ -56,19 +59,19 @@ endef
 
 define Package/rrdcgi1/description
 Round Robin Database (RRD) CGI graphing tool.
-       RRD is the Acronym for Round Robin Database. RRD is a system to store and 
-       display time-series data (i.e. network bandwidth, machine-room temperature, 
-       server load average). It stores the data in a very compact way that will 
-       not expand over time, and it presents useful graphs by processing the data 
-       to enforce a certain data density. It can be used either via simple wrapper 
-       scripts (from shell or Perl) or via frontends that poll network devices and 
+       RRD is the Acronym for Round Robin Database. RRD is a system to store and
+       display time-series data (i.e. network bandwidth, machine-room temperature,
+       server load average). It stores the data in a very compact way that will
+       not expand over time, and it presents useful graphs by processing the data
+       to enforce a certain data density. It can be used either via simple wrapper
+       scripts (from shell or Perl) or via frontends that poll network devices and
        put friendly user interface on it.
-       
-       This is version 1.0.x with cgilib-0.4, gd1.3 and libpng-1.0.9 linked into 
-       librrd.so. The library is much smaller compared to the 1.2.x version with 
+
+       This is version 1.0.x with cgilib-0.4, gd1.3 and libpng-1.0.9 linked into
+       librrd.so. The library is much smaller compared to the 1.2.x version with
        separate dynamic linked libraries.
-       
-       This package contains the rrdcgi tool used to create web pages containing 
+
+       This package contains the rrdcgi tool used to create web pages containing
        RRD graphs based on templates.
 endef
 
@@ -82,18 +85,18 @@ endef
 
 define Package/rrdtool1/description
 Round Robin Database (RRD) management tools.
-       RRD is the Acronym for Round Robin Database. RRD is a system to store and 
-       display time-series data (i.e. network bandwidth, machine-room temperature, 
-       server load average). It stores the data in a very compact way that will 
-       not expand over time, and it presents useful graphs by processing the data 
-       to enforce a certain data density. It can be used either via simple wrapper 
-       scripts (from shell or Perl) or via frontends that poll network devices and 
+       RRD is the Acronym for Round Robin Database. RRD is a system to store and
+       display time-series data (i.e. network bandwidth, machine-room temperature,
+       server load average). It stores the data in a very compact way that will
+       not expand over time, and it presents useful graphs by processing the data
+       to enforce a certain data density. It can be used either via simple wrapper
+       scripts (from shell or Perl) or via frontends that poll network devices and
        put friendly user interface on it.
-       
-       This is version 1.0.x with cgilib-0.4, gd1.3 and libpng-1.0.9 linked into 
-       librrd.so. The library is much smaller compared to the 1.2.x version with 
+
+       This is version 1.0.x with cgilib-0.4, gd1.3 and libpng-1.0.9 linked into
+       librrd.so. The library is much smaller compared to the 1.2.x version with
        separate dynamic linked libraries.
-       
+
        This package contains command line tools used to manage RRDs.
 endef
 
index 6616c34478ca4594440c232f8847608073112403..36e17c6f5751e877b925aa07072b29ea0f7a9778 100644 (file)
@@ -13,7 +13,7 @@ PKG_VERSION:=0.2.0.9-alpha
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://tor.eff.org/dist/ \
+PKG_SOURCE_URL:=http://www.torproject.org/dist/ \
        http://ftp.se.linux.org/crypto/tor/ \
        http://tor.meulie.net/
 PKG_MD5SUM:=47523575d2f6b857c453f37fbd4fca10