disable assertions, add an initscript and some config files
authorNicolas Thill <nico@openwrt.org>
Wed, 24 Aug 2005 02:02:57 +0000 (02:02 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 24 Aug 2005 02:02:57 +0000 (02:02 +0000)
SVN-Revision: 1744

openwrt/package/avahi/Makefile
openwrt/package/avahi/files/avahi-daemon.conf [new file with mode: 0644]
openwrt/package/avahi/files/avahi-daemon.init [new file with mode: 0644]
openwrt/package/avahi/files/service-http [new file with mode: 0644]
openwrt/package/avahi/files/service-ssh [new file with mode: 0644]

index a6b4a626a7002dba4032f436f1aa973a00436531..b5f5b943cd27d17e9c116581ed47c26d79e4acfd 100644 (file)
@@ -23,7 +23,7 @@ $(eval $(call PKG_template,LIBAVAHI,libavahi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARC
 $(PKG_BUILD_DIR)/.configured:
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
+               CFLAGS="$(TARGET_CFLAGS) -DNDEBUG" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
                LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
                PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
@@ -66,6 +66,8 @@ $(PKG_BUILD_DIR)/.configured:
                        --disable-doxygen-pdf \
                        --disable-xmltoman \
                        --with-distro=openwrt \
+                       --with-avahi-user=nobody \
+                       --with-avahi-group=nogroup \
        );
        touch $@
 
@@ -79,8 +81,12 @@ $(PKG_BUILD_DIR)/.built:
 
 $(IPKG_AVAHI_DAEMON):
        install -d -m0755 $(IDIR_AVAHI_DAEMON)/etc/avahi
-       cp -fpR $(PKG_INSTALL_DIR)/etc/avahi/avahi-daemon.conf $(IDIR_AVAHI_DAEMON)/etc/avahi/
-       cp -fpR $(PKG_INSTALL_DIR)/etc/avahi/services $(IDIR_AVAHI_DAEMON)/etc/avahi/
+       install -m0644 ./files/avahi-daemon.conf $(IDIR_AVAHI_DAEMON)/etc/avahi/
+       install -d -m0755 $(IDIR_AVAHI_DAEMON)/etc/avahi/services
+       install -m0644 ./files/service-http $(IDIR_AVAHI_DAEMON)/etc/avahi/services/http.service
+       install -m0644 ./files/service-ssh $(IDIR_AVAHI_DAEMON)/etc/avahi/services/ssh.service
+       install -d -m0755 $(IDIR_AVAHI_DAEMON)/etc/init.d
+       install -m0755 ./files/avahi-daemon.init $(IDIR_AVAHI_DAEMON)/etc/init.d/avahi-daemon
        install -d -m0755 $(IDIR_AVAHI_DAEMON)/usr/sbin
        cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/avahi-daemon $(IDIR_AVAHI_DAEMON)/usr/sbin/
        $(RSTRIP) $(IDIR_AVAHI_DAEMON)
diff --git a/openwrt/package/avahi/files/avahi-daemon.conf b/openwrt/package/avahi/files/avahi-daemon.conf
new file mode 100644 (file)
index 0000000..a5ff886
--- /dev/null
@@ -0,0 +1,29 @@
+[server]
+#host-name=foo
+#domain-name=local
+use-ipv4=yes
+use-ipv6=no
+check-response-ttl=no
+use-iff-running=no
+enable-dbus=no
+
+[publish]
+publish-addresses=yes
+publish-hinfo=yes
+publish-workstation=no
+publish-domain=yes
+#publish-dns-servers=192.168.1.1
+#publish-resolv-conf-dns-servers=yes
+
+[reflector]
+enable-reflector=no
+reflect-ipv=no
+
+[rlimits]
+#rlimit-as=
+rlimit-core=0
+rlimit-data=4194304
+rlimit-fsize=0
+rlimit-nofile=30
+rlimit-stack=4194304
+rlimit-nproc=1
diff --git a/openwrt/package/avahi/files/avahi-daemon.init b/openwrt/package/avahi/files/avahi-daemon.init
new file mode 100644 (file)
index 0000000..20f0a2e
--- /dev/null
@@ -0,0 +1,25 @@
+#!/bin/sh
+
+BIN=avahi-daemon
+DEFAULT=/etc/default/$BIN
+OPTIONS="-D"
+RUN_D=/var/run/$BIN
+[ -f $DEFAULT ] && . $DEFAULT
+
+case $1 in
+ start)
+  mkdir -p $RUN_D
+  $BIN $OPTIONS
+  ;;
+ stop)
+  $BIN -k
+  ;;
+ reload)
+  $BIN -r
+  ;;
+ *)
+  echo "usage: $0 (start|stop|reload)"
+  exit 1
+esac
+
+exit $?
diff --git a/openwrt/package/avahi/files/service-http b/openwrt/package/avahi/files/service-http
new file mode 100644 (file)
index 0000000..8e0d3a5
--- /dev/null
@@ -0,0 +1,10 @@
+<?xml version="1.0" standalone='no'?><!--*-nxml-*-->
+<!DOCTYPE service-group SYSTEM "avahi-service.dtd">
+<service-group>
+ <name replace-wildcards="yes">Web Server on %h</name>
+  <service>
+   <type>_http._tcp</type>
+   <port>80</port>
+   <txt-record>path=/index.html</txt-record>
+  </service>
+</service-group>
diff --git a/openwrt/package/avahi/files/service-ssh b/openwrt/package/avahi/files/service-ssh
new file mode 100644 (file)
index 0000000..b415803
--- /dev/null
@@ -0,0 +1,9 @@
+<?xml version="1.0" standalone='no'?><!--*-nxml-*-->
+<!DOCTYPE service-group SYSTEM "avahi-service.dtd">
+<service-group>
+ <name replace-wildcards="yes">Secure Shell on %h</name>
+  <service>
+   <type>_ssh._tcp</type>
+   <port>22</port>
+  </service>
+</service-group>