Firmwarehotplug actually requires a sdcc that supports some targets, Debian lenny...
authorFlorian Fainelli <florian@openwrt.org>
Mon, 13 Oct 2008 15:45:11 +0000 (15:45 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 13 Oct 2008 15:45:11 +0000 (15:45 +0000)
SVN-Revision: 12974

utils/firmwarehotplug/Makefile

index ecde073613afedeec2a81a8d53d85da40ea6708c..16e5c977439dc373526e28bea8e58d1315148511 100644 (file)
@@ -50,6 +50,16 @@ endef
 
 $(eval $(call BuildPackage,firmwarehotplug))
 
 
 $(eval $(call BuildPackage,firmwarehotplug))
 
-$(eval $(call RequireCommand,sdcc-nf, \
+define Require/working-sdcc
+       sdcc -v | awk '($$$$1 == "SDCC") && ($$$$3 == "mcs51/gbz80/z80/avr/ds390/pic16/pic14/TININative/xa51/ds400/hc08") { print "ok" }' | grep ok > /dev/null
+endef
+
+$(eval $(call RequireCommand,sdcc, \
         $(PKG_NAME) requires the SDCC Cross Compiler (sdcc). \
 ))
         $(PKG_NAME) requires the SDCC Cross Compiler (sdcc). \
 ))
+
+$(eval $(call Require,working-sdcc, \
+        $(PKG_NAME) requires a SDCC Cross Compiler (sdcc) that supports the following targets : \
+       mcs51/gbz80/z80/avr/ds390/pic16/pic14/TININative/xa51/ds400/hc08. You might consider \
+       installing the non-free version. \
+))