[packages] babeld: new upstream release 1.4.0
authorGabriel Kerneis <kerneis@pps.jussieu.fr>
Thu, 9 May 2013 15:52:33 +0000 (15:52 +0000)
committerGabriel Kerneis <kerneis@pps.jussieu.fr>
Thu, 9 May 2013 15:52:33 +0000 (15:52 +0000)
Two new options in uci config:
  * smoothing_half_time (-M)
    Specify the half-time in seconds of the exponential decay used for
    smoothing metrics for performing route selection; the value 0 disables
    smoothing. The default is 4s.
  * random_router_id (-r)
    Use a random router-id. The default is to use persistent router-ids
    derived from the MAC address of the first interface, which is easier
    to debug and more reliably prevents routing loops but may sometimes
    cause a node to be unreachable for 120 seconds just after boot.

Upstream changes:
3 May 2013: babeld-1.4.0
  * Change the route selection algorithm to used a smoothed metric in
    addition to the "real" metric. This reduces the amount of route
    flapping without any special case hacks.
  * New flag -r, use a random router-id. This avoids temporarily
    unreachable nodes after a reboot when persistent storage is not
    available.
  * INCOMPATIBLE CHANGE: the local interface now announces the local
    hostname, and marks the end of the initial route dump. (Thanks to
    Gabriel Kerneis.)
  * The local interface is now able to accept multiple simultaneous
    connections.
  * Detect BATMAN interfaces, don't assume they are wired.

SVN-Revision: 36586

net/babel/Makefile
net/babel/files/babeld.config
net/babel/files/babeld.init

index b51820729869d5d4a57618ed69a710ec9b2e8c3b..a3fde8c09d8d76a7b251e520719d6e05e495ee17 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=babeld
-PKG_VERSION:=1.3.6
+PKG_VERSION:=1.4.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.pps.univ-paris-diderot.fr/~jch/software/files/
-PKG_MD5SUM:=5dfccfeb2db5d8244c2fd2dc301e89a0
+PKG_MD5SUM:=4ad44bca59f594a629306ac5c9b89d57
 
 include $(INCLUDE_DIR)/package.mk
 
index 688da5a4f9d1c0c953201a899851be8ae91e8d0b..ba60d981245ab040747cb470a2c8bf9582c483a1 100644 (file)
@@ -7,6 +7,7 @@ config general
        # option 'hello_interval' '4'
        # option 'wired_hello_interval' '20'
        # option 'diversity' '0,128'
+       # option 'smoothing_half_time' '4'
        # option 'kernel_priority' '0'
        # Do not use this option unless you know what you are doing, as it can
        # cause persistent route flapping.
@@ -17,6 +18,7 @@ config general
        # option 'debug' '0'
        # Listen for connections from a front-end, e.g. on port 33123.
        ## option 'local_server' '33123'
+       # option 'random_router_id' 'false'
        # Keep unfeasible routes
        ## option 'keep_unfeasible' 'false'
        # Use the given kernel routing table for routes inserted by babeld.
index 67a35448104e913db04563c3da4c752f9f18d6e3..d33f21370cd551de12bac8b0f327ede7f9e26711 100755 (executable)
@@ -98,6 +98,7 @@ babel_config() {
        append_bool "$cfg" 'assume_wireless' '-w'
        append_bool "$cfg" 'no_split_horizon' '-s'
        append_bool "$cfg" 'keep_unfeasible' '-u'
+       append_bool "$cfg" 'random_router_id' '-r'
 
        append_parm "$cfg" 'multicast_address' '-m'
        append_parm "$cfg" 'port' '-p'
@@ -105,6 +106,7 @@ babel_config() {
        append_parm "$cfg" 'hello_interval' '-h'
        append_parm "$cfg" 'wired_hello_interval' '-H'
        append_parm "$cfg" 'diversity' '-z'
+       append_parm "$cfg" 'smoothing_half_time' '-M'
        append_parm "$cfg" 'kernel_priority' '-k'
        append_parm "$cfg" 'duplication_priority' '-A'
        append_parm "$cfg" 'debug' '-d'