packages: move 4th to the languages section
authorGabor Juhos <juhosg@openwrt.org>
Fri, 6 Apr 2012 06:51:19 +0000 (06:51 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 6 Apr 2012 06:51:19 +0000 (06:51 +0000)
SVN-Revision: 31210

devel/4th/Makefile [deleted file]
lang/4th/Makefile [new file with mode: 0644]

diff --git a/devel/4th/Makefile b/devel/4th/Makefile
deleted file mode 100644 (file)
index eaabdd6..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-#
-# This is free software, licensed under the GNU General Public License v2.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=4th
-PKG_VERSION:=3.61.3
-PKG_RELEASE:=4
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-nano.tar.gz
-PKG_SOURCE_URL:=http://4th.googlecode.com/files/
-
-include $(INCLUDE_DIR)/package.mk
-define Package/4th
-       MAINTAINER:="Xiangfu Liu" <xiangfu@sharism.cc>
-       TITLE:=4th
-       SECTION:=Programming
-       CATEGORY:=prog
-       URL:=http://thebeez.home.xs4all.nl/4tH/
-endef
-PKG_BUILD_DIR:=$(BUILD_DIR)/4th-$(PKG_VERSION)
-define Package/4th/description
-4th forth compiler
-endef
-
-MAKE_VARS+=LIBRARIES="${PKG_INSTALL_DIR}/usr/lib" BINARIES="${PKG_INSTALL_DIR}/usr/bin"
-MAKE_FLAGS+=-C $(PKG_BUILD_DIR)/sources -f Makefile.NAN
-
-define Package/4th/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/sources/4th $(1)/usr/bin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/sources/4tsh $(1)/usr/bin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/sources/pp4th $(1)/usr/bin/
-       $(CP) $(PKG_BUILD_DIR)/sources/lib4th.a $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,4th))
diff --git a/lang/4th/Makefile b/lang/4th/Makefile
new file mode 100644 (file)
index 0000000..f90a6e9
--- /dev/null
@@ -0,0 +1,38 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=4th
+PKG_VERSION:=3.61.3
+PKG_RELEASE:=4
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-nano.tar.gz
+PKG_SOURCE_URL:=http://4th.googlecode.com/files/
+
+include $(INCLUDE_DIR)/package.mk
+define Package/4th
+       MAINTAINER:="Xiangfu Liu" <xiangfu@sharism.cc>
+       TITLE:=4th
+       SECTION:=lang
+       CATEGORY:=Languages
+       URL:=http://thebeez.home.xs4all.nl/4tH/
+endef
+PKG_BUILD_DIR:=$(BUILD_DIR)/4th-$(PKG_VERSION)
+define Package/4th/description
+4th forth compiler
+endef
+
+MAKE_VARS+=LIBRARIES="${PKG_INSTALL_DIR}/usr/lib" BINARIES="${PKG_INSTALL_DIR}/usr/bin"
+MAKE_FLAGS+=-C $(PKG_BUILD_DIR)/sources -f Makefile.NAN
+
+define Package/4th/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/sources/4th $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/sources/4tsh $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/sources/pp4th $(1)/usr/bin/
+       $(CP) $(PKG_BUILD_DIR)/sources/lib4th.a $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,4th))