[package] unbreak iptables-snmp compilation (#5549)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 1 Aug 2009 23:18:22 +0000 (23:18 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 1 Aug 2009 23:18:22 +0000 (23:18 +0000)
SVN-Revision: 17090

net/iptables-snmp/Makefile
net/iptables-snmp/patches/001-use_libiptc.patch [new file with mode: 0644]

index acfbe9705790f128a8576cb63ad14d9832e60a60..f6abb571e206e9cf08d040cb92187f54a72b4c71 100644 (file)
@@ -20,7 +20,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/iptables-snmp
   SECTION:=net
   CATEGORY:=Network
 define Package/iptables-snmp
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+snmpd @BROKEN
+  DEPENDS:=+snmpd +libiptc
   TITLE:=An snmpd plugin to access iptables rules
   URL:=http://www.nobiscuit.com/iptables-snmp/
   SUBMENU:=firewall
   TITLE:=An snmpd plugin to access iptables rules
   URL:=http://www.nobiscuit.com/iptables-snmp/
   SUBMENU:=firewall
@@ -33,6 +33,7 @@ endef
 define Build/Compile   
        $(call Build/Compile/Default, \
                INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
 define Build/Compile   
        $(call Build/Compile/Default, \
                INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
                all install \
        )
 endef
                all install \
        )
 endef
diff --git a/net/iptables-snmp/patches/001-use_libiptc.patch b/net/iptables-snmp/patches/001-use_libiptc.patch
new file mode 100644 (file)
index 0000000..a142237
--- /dev/null
@@ -0,0 +1,25 @@
+diff -urN iptables-snmp-0.1/Makefile.in iptables-snmp-0.1.new/Makefile.in
+--- iptables-snmp-0.1/Makefile.in      2005-11-02 13:00:10.000000000 +0100
++++ iptables-snmp-0.1.new/Makefile.in  2009-08-02 01:13:40.000000000 +0200
+@@ -67,7 +67,7 @@
+ all: iptables-snmp.so
+-iptables-snmp.so: $(OBJS) libiptc.a Makefile
++iptables-snmp.so: $(OBJS) Makefile
+       $(CC) $(CFLAGS) $(OTHER) $(DFLAGS) -shared  -o $@ $(OBJS) $(LDFLAGS)
+ libiptc.a: $(LIBIPTC_OBJS) Makefile
+diff -urN iptables-snmp-0.1/iptables-snmp.c iptables-snmp-0.1.new/iptables-snmp.c
+--- iptables-snmp-0.1/iptables-snmp.c  2005-11-02 12:10:54.000000000 +0100
++++ iptables-snmp-0.1.new/iptables-snmp.c      2009-08-02 01:13:30.000000000 +0200
+@@ -37,6 +37,9 @@
+ #include "libiptc/libiptc.h"
++/* For backward compatibility */
++typedef struct iptc_handle *iptc_handle_t;
++
+ static oid agent_version_oid[] = {
+     BASE_OID, 1, 0, AGENT_VERSION_INDEX
+ };