[package] update owfs to 2.8p1, patch from Nicolas Leonard
authorFlorian Fainelli <florian@openwrt.org>
Sat, 4 Sep 2010 16:11:45 +0000 (16:11 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 4 Sep 2010 16:11:45 +0000 (16:11 +0000)
SVN-Revision: 22896

utils/owfs/Makefile
utils/owfs/patches/100-configure.patch [deleted file]

index 2e58418f9020f07470272abea0b640caa8701e4e..654d79db29b6019b78011f02a8eed0ec825bdbc9 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=owfs
-PKG_VERSION:=2.7p21
-PKG_RELEASE:=2
+PKG_VERSION:=2.8p1
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=8aea6f3bb0dc9fdb52ed3f0e9d84fa79
+PKG_MD5SUM:=1f7e5482e86d7c2a916fc020b8d4d584
 
 PKG_FIXUP:=libtool
 PKG_INSTALL:=1
@@ -33,18 +33,18 @@ define Package/$(PKG_NAME)/Default
 endef
 
 define Package/$(PKG_NAME)/Default/description
-  OWFS is a suite of programs that designed to make the 1-wire bus and its 
-  devices easily accessible. The underlying priciple is to create a virtual 
-  filesystem, with the unique ID being the directory, and the individual 
-  properties of the device are represented as simple files that can be read 
+  OWFS is a suite of programs that designed to make the 1-wire bus and its
+  devices easily accessible. The underlying priciple is to create a virtual
+  filesystem, with the unique ID being the directory, and the individual
+  properties of the device are represented as simple files that can be read
   and written.
 
-  Details of the individual slave or master design are hidden behind a 
-  consistent interface. The goal is to provide an easy set of tools for a 
-  software designer to create monitoring or control applications. There are 
-  some performance enhancements in the implementation, including data caching, 
-  parallel access to bus masters, and aggregation of device communication. 
-  Still the fundemental goal has been ease of use, flexibility and correctness 
+  Details of the individual slave or master design are hidden behind a
+  consistent interface. The goal is to provide an easy set of tools for a
+  software designer to create monitoring or control applications. There are
+  some performance enhancements in the implementation, including data caching,
+  parallel access to bus masters, and aggregation of device communication.
+  Still the fundemental goal has been ease of use, flexibility and correctness
   rather than speed.
 endef
 
@@ -78,7 +78,7 @@ endef
 
 define Package/libow/description
   $(call Package/$(PKG_NAME)/Default/description)
-  
+
   This package contains the OWFS library.
 endef
 
@@ -90,7 +90,7 @@ endef
 
 define Package/libow-capi/description
   $(call Package/$(PKG_NAME)/Default/description)
-  
+
   This package contains the OWFS C-API library.
 endef
 
@@ -105,7 +105,7 @@ endef
 
 define Package/owshell/description
   $(call Package/$(PKG_NAME)/Default/description)
-  
+
   This package contains the OWFS shell utilities.
 endef
 
@@ -118,7 +118,7 @@ endef
 
 define Package/owfs/description
   $(call Package/$(PKG_NAME)/Default/description)
-  
+
   This package contains the OWFS fuse filesystem.
 endef
 
@@ -133,7 +133,7 @@ endef
 
 define Package/owhttpd/description
   $(call Package/$(PKG_NAME)/Default/description)
-  
+
   This package contains the OWFS http server.
 endef
 
@@ -144,7 +144,7 @@ endef
 
 define Package/owftpd/description
   $(call Package/$(PKG_NAME)/Default/description)
-  
+
   This package contains the OWFS ftp server.
 endef
 
@@ -155,7 +155,7 @@ endef
 
 define Package/owserver/description
   $(call Package/$(PKG_NAME)/Default/description)
-  
+
   This package contains the OWFS network server.
 endef
 
@@ -185,11 +185,6 @@ CONFIGURE_VARS += \
        lt_cv_sys_lib_search_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
        shrext_cmds=".so" \
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); ./bootstrap)
-       $(call Build/Configure/Default)
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(STAGING_DIR)/usr/include
        $(CP)   $(PKG_INSTALL_DIR)/usr/include/ow{capi,fs_config}.h $(STAGING_DIR)/usr/include/
diff --git a/utils/owfs/patches/100-configure.patch b/utils/owfs/patches/100-configure.patch
deleted file mode 100644 (file)
index 2898a7f..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
---- owfs-2.2p0RC/configure.orig        2006-02-02 04:18:08.000000000 +0100
-+++ owfs-2.2p0RC/configure     2006-02-08 20:30:34.000000000 +0100
-@@ -8035,6 +8035,12 @@
- else
-   sys_lib_search_path_spec="/lib /usr/lib /usr/local/lib"
- fi
-+if test "x$lt_sys_lib_search_path_spec" != "x"; then
-+  sys_lib_search_path_spec="$lt_sys_lib_search_path_spec $sys_lib_search_path_spec"
-+fi
-+if test "x$lt_sys_lib_dlsearch_path_spec" != "x"; then
-+  sys_lib_dlsearch_path_spec="$lt_sys_lib_search_path_spec $sys_lib_search_path_spec"
-+fi
- need_lib_prefix=unknown
- hardcode_into_libs=no
-@@ -11827,6 +11833,12 @@
- else
-   sys_lib_search_path_spec="/lib /usr/lib /usr/local/lib"
- fi
-+if test "x$lt_sys_lib_search_path_spec" != "x"; then
-+  sys_lib_search_path_spec="$lt_sys_lib_search_path_spec $sys_lib_search_path_spec"
-+fi
-+if test "x$lt_sys_lib_dlsearch_path_spec" != "x"; then
-+  sys_lib_dlsearch_path_spec="$lt_sys_lib_search_path_spec $sys_lib_search_path_spec"
-+fi
- need_lib_prefix=unknown
- hardcode_into_libs=no
-@@ -15100,6 +15112,12 @@
- else
-   sys_lib_search_path_spec="/lib /usr/lib /usr/local/lib"
- fi
-+if test "x$lt_sys_lib_search_path_spec" != "x"; then
-+  sys_lib_search_path_spec="$lt_sys_lib_search_path_spec $sys_lib_search_path_spec"
-+fi
-+if test "x$lt_sys_lib_dlsearch_path_spec" != "x"; then
-+  sys_lib_dlsearch_path_spec="$lt_sys_lib_search_path_spec $sys_lib_search_path_spec"
-+fi
- need_lib_prefix=unknown
- hardcode_into_libs=no
-@@ -17574,6 +17592,12 @@
- else
-   sys_lib_search_path_spec="/lib /usr/lib /usr/local/lib"
- fi
-+if test "x$lt_sys_lib_search_path_spec" != "x"; then
-+  sys_lib_search_path_spec="$lt_sys_lib_search_path_spec $sys_lib_search_path_spec"
-+fi
-+if test "x$lt_sys_lib_dlsearch_path_spec" != "x"; then
-+  sys_lib_dlsearch_path_spec="$lt_sys_lib_search_path_spec $sys_lib_search_path_spec"
-+fi
- need_lib_prefix=unknown
- hardcode_into_libs=no