[lantiq] fix falcon profile
authorJohn Crispin <john@openwrt.org>
Sun, 16 Dec 2012 10:03:23 +0000 (10:03 +0000)
committerJohn Crispin <john@openwrt.org>
Sun, 16 Dec 2012 10:03:23 +0000 (10:03 +0000)
SVN-Revision: 34713

target/linux/lantiq/falcon/config-default
target/linux/lantiq/falcon/profiles/000-generic.mk [deleted file]
target/linux/lantiq/falcon/profiles/001-lantiq.mk [deleted file]
target/linux/lantiq/falcon/profiles/lantiq.mk [new file with mode: 0644]

index 88a6f3c5f0a8e2a2f81350d450170f816a69bdc3..fef4015f263bfcccd24911e80c781a7d47d40744 100644 (file)
@@ -1,5 +1,9 @@
 CONFIG_GPIO_FALCON=y
 CONFIG_GPIO_GENERIC=y
+CONFIG_I2C=y
+CONFIG_I2C_BOARDINFO=y
+CONFIG_I2C_CHARDEV=y
+# CONFIG_I2C_LANTIQ is not set
 CONFIG_M25PXX_USE_FAST_READ=y
 CONFIG_MTD_M25P80=y
 CONFIG_MTD_NAND=y
@@ -7,6 +11,7 @@ CONFIG_MTD_NAND_ECC=y
 CONFIG_MTD_NAND_FALCON=y
 CONFIG_MTD_NAND_PLATFORM=y
 # CONFIG_MTD_SM_COMMON is not set
+CONFIG_OF_I2C=y
 CONFIG_PINCTRL_FALCON=y
 CONFIG_SOC_FALCON=y
 # CONFIG_SOC_TYPE_XWAY is not set
diff --git a/target/linux/lantiq/falcon/profiles/000-generic.mk b/target/linux/lantiq/falcon/profiles/000-generic.mk
deleted file mode 100644 (file)
index 480e58e..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-define Profile/Generic
-  NAME:=Generic - all boards
-  PACKAGES:= \
-       kmod-dm9000 \
-       kmod-i2c-core kmod-i2c-falcon-lantiq kmod-eeprom-at24 \
-       kmod-spi-bitbang kmod-spi-gpio kmod-eeprom-at25 \
-       gpon-dti-agent
-endef
-
-$(eval $(call Profile,Generic))
-
-
diff --git a/target/linux/lantiq/falcon/profiles/001-lantiq.mk b/target/linux/lantiq/falcon/profiles/001-lantiq.mk
deleted file mode 100644 (file)
index fa42b62..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-define Profile/EASY98000
-  NAME:=EASY98000
-  PACKAGES:= \
-       kmod-dm9000 \
-       kmod-i2c-core kmod-i2c-algo-bit kmod-i2c-gpio kmod-eeprom-at24 \
-       kmod-spi-bitbang kmod-spi-gpio kmod-eeprom-at25
-endef
-
-define Profile/EASY98000/Description
-       Lantiq EASY98000 evalkit
-endef
-
-$(eval $(call Profile,EASY98000))
-
-define Profile/EASY98020
-  NAME:=EASY98020
-endef
-
-define Profile/EASY98020/Description
-       Lantiq EASY98020 evalkit
-endef
-
-$(eval $(call Profile,EASY98020))
-
diff --git a/target/linux/lantiq/falcon/profiles/lantiq.mk b/target/linux/lantiq/falcon/profiles/lantiq.mk
new file mode 100644 (file)
index 0000000..ab60ff5
--- /dev/null
@@ -0,0 +1,19 @@
+define Profile/EASY98000NOR
+  NAME:=Lantiq Falcon - EASY98000NOR
+  PACKAGES:= \
+       kmod-dm9000 \
+       kmod-i2c-core kmod-i2c-algo-bit kmod-i2c-gpio kmod-eeprom-at24 \
+       kmod-spi-bitbang kmod-spi-gpio kmod-eeprom-at25
+endef
+
+$(eval $(call Profile,EASY98000NOR))
+
+define Profile/EASY98000SFLASH
+  NAME:=Lantiq Falcon - EASY98000SFLASH
+  PACKAGES:= \
+       kmod-dm9000 \
+       kmod-i2c-core kmod-i2c-algo-bit kmod-i2c-gpio kmod-eeprom-at24 \
+       kmod-spi-bitbang kmod-spi-gpio kmod-eeprom-at25
+endef
+
+$(eval $(call Profile,EASY98000SFLASH))