[packages] reiserfsprogs: update to v3.6.21, update download URL, cleanup
authorNicolas Thill <nico@openwrt.org>
Mon, 5 Oct 2009 12:41:31 +0000 (12:41 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 5 Oct 2009 12:41:31 +0000 (12:41 +0000)
SVN-Revision: 17875

utils/reiserfsprogs/Makefile
utils/reiserfsprogs/patches/001-header-fix.patch [deleted file]

index 42b682b6aec28354c1295a0ac03f1a749eba7443..073a3df8b6054ef90ffb3a8660a4b9dba97a1f5f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=reiserfsprogs
-PKG_VERSION:=3.6.19
+PKG_VERSION:=3.6.21
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://ftp.namesys.com/pub/reiserfsprogs
-PKG_MD5SUM:=b42cf15f6651c3ceff5cb84996c0d539
+PKG_SOURCE_URL:=@KERNEL/linux/utils/fs/reiserfs/
+PKG_MD5SUM:=
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
diff --git a/utils/reiserfsprogs/patches/001-header-fix.patch b/utils/reiserfsprogs/patches/001-header-fix.patch
deleted file mode 100644 (file)
index 09fdff9..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-Index: reiserfsprogs-3.6.19/include/reiserfs_fs.h
-===================================================================
---- reiserfsprogs-3.6.19.orig/include/reiserfs_fs.h    2008-02-28 18:10:11.000000000 +0100
-+++ reiserfsprogs-3.6.19/include/reiserfs_fs.h 2008-02-28 18:11:35.000000000 +0100
-@@ -38,15 +38,21 @@
- # define extern_inline
- #endif
--#include <asm/unaligned.h>
-+#define get_unaligned(ptr)                  \
-+({                                             \
-+      struct __attribute__((packed)) {        \
-+      typeof(*(ptr)) __v;             \
-+      }  *__p = (void *)(ptr);                \
-+      __p->__v;                               \
-+})
--#ifndef get_unaligned
--#if defined(__ppc__) || defined(ppc) || defined(__ppc) || \
--    defined(__PPC) || defined(powerpc) || defined(__powerpc__)
--#     define get_unaligned(ptr)       (*(ptr))
--#     define put_unaligned(val,ptr)   ((void)(*(ptr) = (val)))
--#endif
--#endif
-+#define put_unaligned(val, ptr)             \
-+do {                                           \
-+      struct __attribute__((packed)) {        \
-+      typeof(*(ptr)) __v;             \
-+      }  *__p = (void *)(ptr);                \
-+      __p->__v = (val);                       \
-+} while(0)
- #define get_leXX(xx,p,field)  (le##xx##_to_cpu ((p)->field))
- #define set_leXX(xx,p,field,val) do { (p)->field = cpu_to_le##xx(val); } while (0)