base-files: Fix a typo in config_list_foreach
authorSteven Barth <cyrus@openwrt.org>
Thu, 27 Dec 2012 14:10:01 +0000 (14:10 +0000)
committerSteven Barth <cyrus@openwrt.org>
Thu, 27 Dec 2012 14:10:01 +0000 (14:10 +0000)
SVN-Revision: 34893

package/base-files/Makefile
package/base-files/files/lib/functions.sh

index 63350f822ac0e88e8297cfc016d7df10dfa7b57e..0e72c188d56a039ee280b2ee7708fbfc0d9584d7 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=122
+PKG_RELEASE:=123
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index 54e69b8332a23372d7298106e509fdf696a4d735..ae0257a5c5973fe0eb91a3e43c2d2dc016b543f5 100755 (executable)
@@ -197,7 +197,7 @@ config_list_foreach() {
        [ -z "$len" ] && return 0
        while [ $c -le "$len" ]; do
                config_get val "${section}" "${option}_ITEM$c"
-               eval "$function \"\$val\" \"$@\""
+               eval "$function \"\$val\" \"\$@\""
                c="$(($c + 1))"
        done
 }