[packages] miniupnpd: always (re)start from hotplug handler, make boot() a no-op...
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 5 Jun 2012 12:56:42 +0000 (12:56 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 5 Jun 2012 12:56:42 +0000 (12:56 +0000)
SVN-Revision: 32056

net/miniupnpd/Makefile
net/miniupnpd/files/miniupnpd.iface.hotplug

index 71f3b781c32de873fd0c7bd10e679ecddc72a4e4..dcbc557d77a1a10c872b23182a09c434c3580cc1 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=miniupnpd
 PKG_VERSION:=1.6.20110730
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 
 PKG_SOURCE_URL:=http://miniupnp.free.fr/files
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
index 32d5272576b1be8da9be69047738dd351c509c5a..472b8c2e775473e69a397558a2daf524625a7fe0 100644 (file)
@@ -1,8 +1,8 @@
 #!/bin/sh
 
-/etc/init.d/miniupnpd enabled && [ -n "`pidof miniupnpd`" ] && [ "$ACTION" = "ifup" ] && {
-       local intif
-       for intif in $(uci_get upnpd config internal_iface); do
-               [ "$INTERFACE" = "$intif" ] && /etc/init.d/miniupnpd restart
+/etc/init.d/miniupnpd enabled && [ "$ACTION" = "ifup" ] && {
+       local iface
+       for iface in $(uci_get upnpd config internal_iface; uci_get upnpd config external_iface); do
+               [ "$INTERFACE" = "$iface" ] && /etc/init.d/miniupnpd restart
        done
 }